summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-08-06 22:02:05 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-08-07 16:02:24 +0200
commit01f240a183be2461106e31ba219479262a92c10d (patch)
treef234774aab7c73863db35a8a5a825e8b82c240fd
parentdev-libs/weston: Add mising python_check_deps function (diff)
downloadgentoo-01f240a183be2461106e31ba219479262a92c10d.tar.gz
gentoo-01f240a183be2461106e31ba219479262a92c10d.tar.bz2
gentoo-01f240a183be2461106e31ba219479262a92c10d.zip
dev-ml/gapi-ocaml: add 0.4.4
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/gapi-ocaml/Manifest1
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/Manifest b/dev-ml/gapi-ocaml/Manifest
index 2785e200c86c..8fe08669fed9 100644
--- a/dev-ml/gapi-ocaml/Manifest
+++ b/dev-ml/gapi-ocaml/Manifest
@@ -1,2 +1,3 @@
DIST gapi-ocaml-0.4.2.tar.gz 466749 BLAKE2B 6a3e66618ed9a665de2892dc7657268f3bad43b871d6d761148152d61de2d988bc13b5051e39da4d1ddad0c620237c6018b87cd2303bc086c570aa879c197e4f SHA512 57d933c2d47ef7b80cb55b661f8df1b8642ff301d54f0fd1dfd4a9bc6238a4cb93a308e6918bbbc080fac146cf5fca2ccfe149d0528a63ead5e29e452c9cc427
DIST gapi-ocaml-0.4.3.tar.gz 468450 BLAKE2B 5e9aeef8cdd49e64bedc4494dd60a867b16fe0d02945efcb9ea752a7dd71abfd2dad66354cdf61803cdaa93bfee33079b1a8427ac0279cc93961a62c87498390 SHA512 fb58910639db9d1a0f90c6f224d91af53d2c68611f3faea321db82cc4af940f54e4ae93ee20520ef4337dd1345b8c9961915a8706336a25d4e5a187adde1b2f2
+DIST gapi-ocaml-0.4.4.tar.gz 473064 BLAKE2B 47f401c89107e24c07d3076a5e8dbb2b383270abc138470b78680347cc3d5759227a9a56956217324adf354996d9ea018926dc887cba2cd7ea2fdc43293dbaaa SHA512 3ff319f3563d1fb465cbd4151713c5c1bb3f3ce1f8a2c0d6f938eb99d91844f97cce7c127c52fe970f0f095ced513b3cc440837540631e76037d1882b6d9b820
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.4.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.4.ebuild
new file mode 100644
index 000000000000..3b7a8af6966d
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune findlib
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=
+ >=dev-ml/ocamlnet-4.1.4:=
+ dev-ml/cryptokit:=
+ dev-ml/yojson:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"