summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-03-02 17:11:39 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-03-02 17:11:46 -0600
commit01f3512592d5830c0d1442a4df3043cec905fc02 (patch)
treebaa6b1f40892f4d2f576de4f000439da21cfaa7b
parentdev-util/meson: fix qt tests (diff)
downloadgentoo-01f35125.tar.gz
gentoo-01f35125.tar.bz2
gentoo-01f35125.zip
dev-util/meson: sync live
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-util/meson/meson-9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-util/meson/meson-9999.ebuild b/dev-util/meson/meson-9999.ebuild
index 6149ebc1ee51..31d9ff7f79ec 100644
--- a/dev-util/meson/meson-9999.ebuild
+++ b/dev-util/meson/meson-9999.ebuild
@@ -42,12 +42,11 @@ python_prepare_all() {
}
src_test() {
- if tc-is-gcc; then
- # LTO fails for static libs because the bfd plugin in missing.
- # Remove this workaround after sys-devel/gcc-config-2.0 is stable.
- # https://bugs.gentoo.org/672706
- tc-getPROG AR gcc-ar >/dev/null
- fi
+ # This is needed because upstream doesn't support installing qtcore
+ # without qtgui in the test suite.
+ # https://bugs.gentoo.org/show_bug.cgi?id=678664
+ has_version 'dev-qt/qtcore' && ! has_version 'dev-qt/qtgui' &&
+ rm -rf "test cases/frameworks/4 qt"
distutils-r1_src_test
}