summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-02-19 17:54:57 -0800
committerZac Medico <zmedico@gentoo.org>2024-02-19 17:55:35 -0800
commit022f1f9c9a89df4d3d3f8cd895c07cdc8fdb59c6 (patch)
tree74e23711080b23caa433e65d24342fd7c1eb044b
parentsys-cluster/minikube: add 1.32.0 (diff)
downloadgentoo-022f1f9c9a89df4d3d3f8cd895c07cdc8fdb59c6.tar.gz
gentoo-022f1f9c9a89df4d3d3f8cd895c07cdc8fdb59c6.tar.bz2
gentoo-022f1f9c9a89df4d3d3f8cd895c07cdc8fdb59c6.zip
app-admin/consul: Disable pie for x86
Bug: https://bugs.gentoo.org/924629 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-admin/consul/consul-1.15.3.ebuild6
-rw-r--r--app-admin/consul/consul-1.15.7.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/app-admin/consul/consul-1.15.3.ebuild b/app-admin/consul/consul-1.15.3.ebuild
index 0e9d8834d60a..b3e17cbf517a 100644
--- a/app-admin/consul/consul-1.15.3.ebuild
+++ b/app-admin/consul/consul-1.15.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,10 @@ src_prepare() {
}
src_compile() {
+ if use x86; then
+ #924629 pie breaks build on x86
+ GOFLAGS=${GOFLAGS//-buildmode=pie}
+ fi
# The dev target sets causes build.sh to set appropriate XC_OS
# and XC_ARCH, and skips generation of an unused zip file,
# avoiding a dependency on app-arch/zip.
diff --git a/app-admin/consul/consul-1.15.7.ebuild b/app-admin/consul/consul-1.15.7.ebuild
index 61b9d17d1af3..2b693c361655 100644
--- a/app-admin/consul/consul-1.15.7.ebuild
+++ b/app-admin/consul/consul-1.15.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,10 @@ src_prepare() {
}
src_compile() {
+ if use x86; then
+ #924629 pie breaks build on x86
+ GOFLAGS=${GOFLAGS//-buildmode=pie}
+ fi
# The dev target sets causes build.sh to set appropriate XC_OS
# and XC_ARCH, and skips generation of an unused zip file,
# avoiding a dependency on app-arch/zip.