summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-24 03:02:00 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-24 03:05:07 -0500
commit02381c768910f0ac57d397a8b199761cadac8616 (patch)
treee5b5cab5982f4af5b45b9d17345d05d7da39274d
parentwww-client/opera-beta: Old. (diff)
downloadgentoo-02381c76.tar.gz
gentoo-02381c76.tar.bz2
gentoo-02381c76.zip
net-misc/openssh: drop X509 glue #603610
Upstream X509 insists on stuffing their patchset full of unrelated crap and have no interest in fixing their misbehavior. Maintaining glue layers to work with other features (like sctp or hpn) is not worth our time. This is one step away from purging X509 entirely.
-rw-r--r--net-misc/openssh/openssh-7.4_p1.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-misc/openssh/openssh-7.4_p1.ebuild b/net-misc/openssh/openssh-7.4_p1.ebuild
index db314b2a76c5..616265af0be7 100644
--- a/net-misc/openssh/openssh-7.4_p1.ebuild
+++ b/net-misc/openssh/openssh-7.4_p1.ebuild
@@ -32,7 +32,7 @@ REQUIRED_USE="ldns? ( ssl )
pie? ( !static )
ssh1? ( ssl )
static? ( !kerberos !pam )
- X509? ( !ldap ssl )
+ X509? ( !hpn !ldap !sctp ssl )
test? ( ssl )"
LIB_DEPEND="
@@ -114,16 +114,9 @@ src_prepare() {
if use X509 ; then
pushd .. >/dev/null
- if use hpn ; then
- pushd ${HPN_PATCH%.*.*} >/dev/null
- epatch "${FILESDIR}"/${P}-hpn-12-x509-9.2-glue.patch
- popd >/dev/null
- fi
- epatch "${FILESDIR}"/${PN}-7.3_p1-sctp-x509-glue.patch
sed -i 's:PKIX_VERSION:SSH_X509:g' "${WORKDIR}"/${X509_PATCH%.*} || die
popd >/dev/null
epatch "${WORKDIR}"/${X509_PATCH%.*}
- epatch "${FILESDIR}"/${P}-x509-9.2-warnings.patch
save_version X509
fi
@@ -134,7 +127,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-7.4_p1-GSSAPI-dns.patch #165444 integrated into gsskex
epatch "${FILESDIR}"/${PN}-6.7_p1-openssl-ignore-status.patch
- epatch "${WORKDIR}"/${SCTP_PATCH%.*}
+ use X509 || epatch "${WORKDIR}"/${SCTP_PATCH%.*}
epatch "${FILESDIR}"/${P}-test-bashism.patch
use abi_mips_n32 && epatch "${FILESDIR}"/${PN}-7.3-mips-seccomp-n32.patch