summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-05-28 16:32:34 -0400
committerTim Harder <radhermit@gentoo.org>2016-05-28 16:37:45 -0400
commit0241e08ac4f988629d1168b7170068cfa978cef4 (patch)
tree09c3184dc3f505128271d3fe5482317791ebfbfe
parentdev-util/pkgcheck: version bump to 0.5.2 (diff)
downloadgentoo-0241e08ac4f988629d1168b7170068cfa978cef4.tar.gz
gentoo-0241e08ac4f988629d1168b7170068cfa978cef4.tar.bz2
gentoo-0241e08ac4f988629d1168b7170068cfa978cef4.zip
dev-python/pychroot: version bump to 0.9.14
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.9.14.ebuild47
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild2
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index d328ae667f95..1258e68e36ce 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1 +1,2 @@
DIST pychroot-0.9.13.tar.gz 25610 SHA256 e94c9c738402f4957e757aa1fdcd2febeaa7cc01df1b1ca0d6adf3324a8bbfce SHA512 ec2773e9285905aa1fc83a69653e830fc83c42c306760bbc9a8bf48cd388b99485a7ec30eef32ef4cc98cf25fe12b9ac1d09ae379c25d4c756d3afbffdfc2243 WHIRLPOOL bff205fb563e7e3f9603a639310cbf24ec10234e96e813082aeec94bc5cb3155947f818f53713a09f0626e5dad21a4d0b4c1c49d26eeb894677872e30bef92b7
+DIST pychroot-0.9.14.tar.gz 29494 SHA256 34168fbc4e8cd50b23ae6248c0c5c669f3b9cd2396f96a961ea4e06abb7c1203 SHA512 3a043d97464bf669fd92b316179f4b3fc8462fe3a84f66aba16e99f7b7e84c382bb146b0dca5b03902235f99636b5693d7de8545f73f5756a2cbb80d73311896 WHIRLPOOL bd9748ad3f821f18808f0bb7c2d0758213934bb57b075f14f01594012609a1d6269bddbc673de47e8d9715a15e8f46d63410c0f4ee3aa08439250ea72fb3cbd3
diff --git a/dev-python/pychroot/pychroot-0.9.14.ebuild b/dev-python/pychroot/pychroot-0.9.14.ebuild
new file mode 100644
index 000000000000..99a012a2d68c
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.9.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/snakeoil-0.7.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ esetup.py build_man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ distutils-r1_python_install install_man
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 31a2e75034b3..b3c192a6f874 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/pkgcore/${PN}/releases/download/v${PV}/${P}.tar.gz"
fi
DESCRIPTION="a python library and cli tool that simplify chroot handling"