summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 14:39:41 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 14:53:13 +0100
commit0244ce207e4eb6f0447998b548ad46780f75feac (patch)
treeb2566f5045ccea97dedb42bf47cbd8bea4dcce2d
parentdev-python/asn1crypto: Enable py3.8 (diff)
downloadgentoo-0244ce20.tar.gz
gentoo-0244ce20.tar.bz2
gentoo-0244ce20.zip
dev-python/iso8601: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/iso8601/iso8601-0.1.12.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-python/iso8601/iso8601-0.1.12.ebuild b/dev-python/iso8601/iso8601-0.1.12.ebuild
index 6020fca39c84..e54fa1b15919 100644
--- a/dev-python/iso8601/iso8601-0.1.12.ebuild
+++ b/dev-python/iso8601/iso8601-0.1.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
inherit distutils-r1
@@ -14,11 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-python_test() {
- "${PYTHON}" -m pytest --verbose ${PN} || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest