summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-20 09:08:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-20 10:54:35 +0100
commit02485feb93f53183e41902199f96782ca169d706 (patch)
tree196d5c4db46cef6bdfd1fe2be180cd7930bef47b
parentsci-mathematics/cgal: new maintainer (diff)
downloadgentoo-02485feb93f53183e41902199f96782ca169d706.tar.gz
gentoo-02485feb93f53183e41902199f96782ca169d706.tar.bz2
gentoo-02485feb93f53183e41902199f96782ca169d706.zip
dev-python/botocore: Bump to 1.19.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.22.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 0aee042c9870..5dd8239783c2 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,4 +2,5 @@ DIST botocore-1.18.18.tar.gz 6942407 BLAKE2B e58183d5aa79a210d82c1dc21806c9c86f9
DIST botocore-1.19.16.tar.gz 7009239 BLAKE2B d582538f25c500297ab8a5ce3f054a5ba2f94d0d5f37d0aeee934943854bb5fc429e33040b56d1e06cfd93a51bd917c96dac9432c5b84d59513b47af52285ac1 SHA512 d36b580e0ad56143b9b36679d17910fcdb49ec132143441d6a078797f79bec1fd6f06b2afb8542e16e844fb892c2902aeab1cfcf66a8ddb9ecbcc92be4ced29d
DIST botocore-1.19.20.tar.gz 7055105 BLAKE2B f25a6aff2073d8fa8de0c787b34239ee434c0616b2666b7191c5303e6d76389c883aca9a2b03243caf989f270f981bb69873ddbbf21a6afdd1073d8a6bb959dd SHA512 24c0e6e6a67d03374f86608762030e42cd14f2010763c57ed06d74a6a514a81dd25f9681bec890795ed6ec1f488aafeaeb3175e7264deb72438dde35e6e8398d
DIST botocore-1.19.21.tar.gz 7060392 BLAKE2B 2539996a3aed89d9e76143c4e899cc09b278ef5fb23ea3b8cacc4af4a3b5287043f193e40ab07937147db70085aef688c8fe432124a0c0fe89f1ae7e2f003bec SHA512 43a656c29944dc3b0c84f321d251b3d135634ac8cd639a9c13a1f04a0e0e1421bd0c2ed8200f7e032faab6b45d7ea64f03991a90e5db837542501ae9f1843d6e
+DIST botocore-1.19.22.tar.gz 7073938 BLAKE2B 41ec38e7abdff5e6fd4530dd39522a13d10c7048564002f5c4c99f9c13cf25b3b4a108ca651bee44f1e00d0b8b560e7c364021793a7fd50e3501ef54c153960e SHA512 69efd9f01cb9cb83d4234be6ad46d2f2584bfd274a96c27279c96d717de4ea83e8bb1b92baa29b06aacf21e0af9e40ab216e5ac7ffe004cc4a53bfcf6c32f59e
DIST botocore-1.19.9.tar.gz 6972834 BLAKE2B 3407c056c7995cc1ccb1b5b4c5b3a6254e38672b52e7889a7a022520283416e4dfcabd05c8ca0ed78e4624c7a20c9f43bfde87a76d7a72660b4c95256e4f9ca4 SHA512 8433f22ae7652e524a82da8d2ccda48da9eef44788333898b7526335d57a7757b80754f0d5c6a2c84ec3bde2ec9fc7da5cf872cbda7286f620b4f4878fe9a583
diff --git a/dev-python/botocore/botocore-1.19.22.ebuild b/dev-python/botocore/botocore-1.19.22.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.22.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}