summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-07-13 10:19:51 +0200
committerPacho Ramos <pacho@gentoo.org>2021-07-13 10:19:51 +0200
commit0259517e874f5c6a977f2e5222ba6797a1bdfa47 (patch)
treedb3cca69eabbfc71b51e3b179549dbee615a5036
parentgnome-base/gnome-shell: Version bump to 40.3 (diff)
downloadgentoo-0259517e874f5c6a977f2e5222ba6797a1bdfa47.tar.gz
gentoo-0259517e874f5c6a977f2e5222ba6797a1bdfa47.tar.bz2
gentoo-0259517e874f5c6a977f2e5222ba6797a1bdfa47.zip
gnome-extra/gnome-shell-extensions: Version bump to 40.3
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extensions/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions/Manifest b/gnome-extra/gnome-shell-extensions/Manifest
index 4edf8cd4c8a9..b3b07e356cb0 100644
--- a/gnome-extra/gnome-shell-extensions/Manifest
+++ b/gnome-extra/gnome-shell-extensions/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extensions-40.1.tar.xz 218084 BLAKE2B 0f54dc53ce279af424658d540961bda698c4d6c2968bf778e626a91c7da47b8f56bd4b1dd874956dce9fbb0d1719bd64b8cf8883788d625049aa14dcc02ff313 SHA512 e537312c0790b6e54b3eebb0df189f65f093e81ec7cf1cde886df747188765775fc4616e98bff0157b543bac26c51a5c7006f1505f4554fea00972f790e781f1
DIST gnome-shell-extensions-40.2.tar.xz 218032 BLAKE2B f4b8daf2fcd62eaef0ad0960c930fc9368bd426b867a31351b39a2a628dfe9c0631419a5f067b4ac1eb03d2df931ba3a8ea99d4e72043459463b86eb00f6787b SHA512 f02a02a8410e77e8c8b0a764bb7949727974e9a4c0125ac2b6e68c1b20b663ef2de82ddaaed882dd5ffb3a6fd9898b372b6201d53da33f11677c32e82272d2aa
+DIST gnome-shell-extensions-40.3.tar.xz 218108 BLAKE2B 33174ef4c80caf375d48f11b7678ec78bfbe60a9d4456e21856b09a0a83e99ee7b68598c719a6913a29d9686317015fbc8d8bfae856e433414889e59e82e5ca3 SHA512 3773b0a5ec81b6663a3b2c5f5d1f8e7619fdba49ce67b25ee0f5555d17ea7c9740c3698b7a4e4f7fa78241c8738663c602cb5ed1ff9874b8ad2321fec0dbc737
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.3.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.3.ebuild
new file mode 100644
index 000000000000..f5bc021adcaa
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org readme.gentoo-r1 meson xdg
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.26:2
+ >=gnome-base/libgtop-2.28.3[introspection]
+ >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${DEPEND}
+ >=dev-libs/gjs-1.29
+ dev-libs/gobject-introspection:=
+ dev-libs/atk[introspection]
+ gnome-base/gnome-menus:3[introspection]
+ =gnome-base/gnome-shell-$(ver_cut 1-2)*
+ media-libs/clutter:1.0[introspection]
+ net-libs/telepathy-glib[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme
+ >=x11-wm/mutter-3.32[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the https://extensions.gnome.org/ web interface, the
+gnome-extra/gnome-tweaks GUI, or modify the org.gnome.shell
+enabled-extensions gsettings key from the command line or a script."
+
+src_configure() {
+ meson_src_configure \
+ -Dextension_set=all \
+ -Dclassic_mode=true
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+
+ readme.gentoo_print_elog
+}