summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-01 11:37:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-01 11:37:21 +0100
commit025a2e666894624c585168d57545e47c9ba8b5e4 (patch)
treee53ea2ac2b8e2b5d7282a08ed5a6189714ac5eec
parentmedia-libs/aubio: Bump to 0.4.2. (diff)
downloadgentoo-025a2e666894624c585168d57545e47c9ba8b5e4.tar.gz
gentoo-025a2e666894624c585168d57545e47c9ba8b5e4.tar.bz2
gentoo-025a2e666894624c585168d57545e47c9ba8b5e4.zip
media-video/dvdstyler: Fix ffmpeg patch and make it unconditional.
Package-Manager: portage-2.2.23
-rw-r--r--media-video/dvdstyler/dvdstyler-2.9.4-r1.ebuild6
-rw-r--r--media-video/dvdstyler/files/dvdstyler-2.9.4-ffmpeg29.patch31
2 files changed, 34 insertions, 3 deletions
diff --git a/media-video/dvdstyler/dvdstyler-2.9.4-r1.ebuild b/media-video/dvdstyler/dvdstyler-2.9.4-r1.ebuild
index 2c5c99424ccd..8e6f47d33e31 100644
--- a/media-video/dvdstyler/dvdstyler-2.9.4-r1.ebuild
+++ b/media-video/dvdstyler/dvdstyler-2.9.4-r1.ebuild
@@ -24,8 +24,8 @@ COMMON_DEPEND=">=app-cdr/dvd+rw-tools-7.1
>=media-video/dvdauthor-0.7.1
>=media-video/xine-ui-0.99.7
virtual/cdrtools
- libav? ( media-video/libav:0=[encode] )
- !libav? ( media-video/ffmpeg:0=[encode] )
+ libav? ( >=media-video/libav-9:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2.6:0=[encode] )
virtual/jpeg:0
x11-libs/wxGTK:${WX_GTK_VER}=[gstreamer,X]
sys-apps/dbus
@@ -54,7 +54,7 @@ src_prepare() {
sed -i \
-e '/Icon/s:.png::' -e '/^Encoding/d' -e '/Categories/s:Application;::' \
data/dvdstyler.desktop || die
- has_version '>=media-video/ffmpeg-2.9' && epatch "${FILESDIR}/ffmpeg29.patch"
+ epatch "${FILESDIR}/${PN}-2.9.4-ffmpeg29.patch"
}
src_configure() {
diff --git a/media-video/dvdstyler/files/dvdstyler-2.9.4-ffmpeg29.patch b/media-video/dvdstyler/files/dvdstyler-2.9.4-ffmpeg29.patch
new file mode 100644
index 000000000000..2ddd41408b59
--- /dev/null
+++ b/media-video/dvdstyler/files/dvdstyler-2.9.4-ffmpeg29.patch
@@ -0,0 +1,31 @@
+Index: DVDStyler-2.9.4/src/mediaenc_ffmpeg.cpp
+===================================================================
+--- DVDStyler-2.9.4.orig/src/mediaenc_ffmpeg.cpp
++++ DVDStyler-2.9.4/src/mediaenc_ffmpeg.cpp
+@@ -179,7 +179,7 @@ bool wxFfmpegMediaEncoder::addVideoStrea
+ c->time_base.den = isNTSC(videoFormat) ? 30000 : 25;
+ c->time_base.num = isNTSC(videoFormat) ? 1001 : 1;
+ c->gop_size = m_gopSize > 0 ? m_gopSize : (isNTSC(videoFormat) ? 15 : 12);
+- c->pix_fmt = PIX_FMT_YUV420P;
++ c->pix_fmt = AV_PIX_FMT_YUV420P;
+ c->rc_buffer_size = VIDEO_BUF_SIZE;
+ c->rc_max_rate = 9000000;
+ c->rc_min_rate = 0;
+@@ -280,7 +280,7 @@ void wxFfmpegMediaEncoder::CloseAudioEnc
+ m_audioStm = NULL;
+ }
+
+-AVFrame* allocPicture(PixelFormat pix_fmt, int width, int height) {
++AVFrame* allocPicture(AVPixelFormat pix_fmt, int width, int height) {
+ AVFrame* frame = av_frame_alloc();
+ if (!frame)
+ return NULL;
+@@ -329,7 +329,7 @@ bool wxFfmpegMediaEncoder::OpenVideoEnco
+ return false;
+ }
+
+- m_imgConvertCtx = sws_getContext(c->width, c->height, PIX_FMT_RGB24, c->width, c->height, c->pix_fmt, SWS_BICUBIC,
++ m_imgConvertCtx = sws_getContext(c->width, c->height, AV_PIX_FMT_RGB24, c->width, c->height, c->pix_fmt, SWS_BICUBIC,
+ NULL, NULL, NULL);
+ if (!m_imgConvertCtx) {
+ wxLogError(wxT("Cannot initialize the conversion context"));