summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-09 11:54:13 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-09 11:55:00 +0100
commit026668dd5d45a6234c97f03ff0fa6e09123516fa (patch)
treea436dafa211e6d4ed2cdb2a112d9f86dd74ba8fe
parentgames-emulation/desmume: Remove myself as maintainer (diff)
downloadgentoo-026668dd5d45a6234c97f03ff0fa6e09123516fa.tar.gz
gentoo-026668dd5d45a6234c97f03ff0fa6e09123516fa.tar.bz2
gentoo-026668dd5d45a6234c97f03ff0fa6e09123516fa.zip
net-analyzer/siphon: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=708800 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/siphon/files/siphon-666-fno-common.patch22
-rw-r--r--net-analyzer/siphon/siphon-666-r2.ebuild34
2 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/siphon/files/siphon-666-fno-common.patch b/net-analyzer/siphon/files/siphon-666-fno-common.patch
new file mode 100644
index 000000000000..c3b1addf1b04
--- /dev/null
+++ b/net-analyzer/siphon/files/siphon-666-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/main.c
++++ b/main.c
+@@ -12,6 +12,9 @@
+
+ #include <siphon.h>
+
++char *device, *logfile;
++int verbose, back;
++
+ void usage (char *);
+ void title(void);
+
+--- a/siphon.h
++++ b/siphon.h
+@@ -51,5 +51,5 @@
+ void *parse (void *);
+ void *siphon_log(void *);
+
+-char *device, *logfile;
+-int verbose, back;
++extern char *device, *logfile;
++extern int verbose, back;
diff --git a/net-analyzer/siphon/siphon-666-r2.ebuild b/net-analyzer/siphon/siphon-666-r2.ebuild
new file mode 100644
index 000000000000..7921c66b9a14
--- /dev/null
+++ b/net-analyzer/siphon/siphon-666-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=${PN}-v.${PV}
+
+DESCRIPTION="A portable passive network mapping suite"
+HOMEPAGE="http://siphon.datanerds.net/"
+SRC_URI="http://siphon.datanerds.net/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-log.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc
+ doins osprints.conf
+ dodoc README
+}