summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall Vasquez <ran.dall@icloud.com>2022-04-13 12:18:21 -0700
committerConrad Kostecki <conikost@gentoo.org>2022-04-14 22:52:10 +0200
commit0277f8d599a2f3834668430ca63f2d87c3c1d6dc (patch)
treeaa944487ed68fbf89bfd171b9cb5d1c4eb2c2b9d
parentsys-auth/AusweisApp2: add 1.22.5 (diff)
downloadgentoo-0277f8d599a2f3834668430ca63f2d87c3c1d6dc.tar.gz
gentoo-0277f8d599a2f3834668430ca63f2d87c3c1d6dc.tar.bz2
gentoo-0277f8d599a2f3834668430ca63f2d87c3c1d6dc.zip
dev-libs/intel-compute-runtime-22.*.*: Filter LTO flags
Closes: https://bugs.gentoo.org/838241 Signed-off-by: Randall Vasquez <ran.dall@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/25018 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild5
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789.ebuild5
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
index 4b6c563cdd2a..fb7f4bdf494f 100644
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.12.22749.ebuild
@@ -7,7 +7,7 @@ CMAKE_BUILD_TYPE="Release"
MY_PN="${PN/intel-/}"
MY_P="${MY_PN}-${PV}"
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
HOMEPAGE="https://github.com/intel/compute-runtime"
@@ -44,6 +44,9 @@ DOCS=( "README.md" "FAQ.md" )
PATCHES=( "${FILESDIR}/${PN}-22.12.22749-metrics.patch" )
src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789.ebuild
index a58424820a2a..eca15c13bd28 100644
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789.ebuild
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789.ebuild
@@ -7,7 +7,7 @@ CMAKE_BUILD_TYPE="Release"
MY_PN="${PN/intel-/}"
MY_P="${MY_PN}-${PV}"
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
HOMEPAGE="https://github.com/intel/compute-runtime"
@@ -42,6 +42,9 @@ BDEPEND="virtual/pkgconfig"
DOCS=( "README.md" "FAQ.md" )
src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild
index a58424820a2a..eca15c13bd28 100644
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild
@@ -7,7 +7,7 @@ CMAKE_BUILD_TYPE="Release"
MY_PN="${PN/intel-/}"
MY_P="${MY_PN}-${PV}"
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
HOMEPAGE="https://github.com/intel/compute-runtime"
@@ -42,6 +42,9 @@ BDEPEND="virtual/pkgconfig"
DOCS=( "README.md" "FAQ.md" )
src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DCMAKE_INSTALL_LIBDIR="$(get_libdir)"