summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-12-20 10:58:03 +0100
committerUlrich Müller <ulm@gentoo.org>2023-12-20 11:00:13 +0100
commit02ac61b498061a3851e094150165ddf4cab93166 (patch)
treed2a7b0ba8de7ec496e6b5ebbf0f8647bc2be637d
parentx11-themes/QGnomePlatform: remove unused patch (diff)
downloadgentoo-02ac61b498061a3851e094150165ddf4cab93166.tar.gz
gentoo-02ac61b498061a3851e094150165ddf4cab93166.tar.bz2
gentoo-02ac61b498061a3851e094150165ddf4cab93166.zip
app-editors/emacs: Append -Wno-return-mismatch to CFLAGS
If you think this should be fixed in the source instead, feel free to submit a patch that adds all the missing prototypes. Closes: https://bugs.gentoo.org/920360 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-editors/emacs/emacs-18.59-r15.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-editors/emacs/emacs-18.59-r15.ebuild b/app-editors/emacs/emacs-18.59-r15.ebuild
index 7844e27bcb93..466b031d91a4 100644
--- a/app-editors/emacs/emacs-18.59-r15.ebuild
+++ b/app-editors/emacs/emacs-18.59-r15.ebuild
@@ -74,11 +74,13 @@ src_configure() {
src/s-linux.h || die
# -O3 and -finline-functions cause segmentation faults at run time.
- # -Wno-implicit and -Wno-return-type will quieten newer versions of GCC;
- # feel free to submit a patch adding all those missing prototypes.
+ # -Wno-implicit, -Wno-return-type and -Wno-return-mismatch will
+ # quieten newer versions of GCC; feel free to submit a patch adding
+ # all those missing prototypes.
strip-flags
filter-flags -finline-functions -fpie
- append-flags -fno-strict-aliasing -Wno-implicit -Wno-return-type
+ append-flags -fno-strict-aliasing -Wno-implicit -Wno-return-type \
+ -Wno-return-mismatch
append-ldflags $(test-flags -no-pie) #639562
replace-flags -O[3-9] -O2
}