summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-18 18:12:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-18 18:19:52 +0200
commit02c000a5dcffea327cf09a325b5aa105274c45fb (patch)
tree31db7c07f8781c0f9babb0bc5bc5a744f5f879a8
parentxfce-base/garcon: Bump to 4.19.0 (diff)
downloadgentoo-02c000a5dcffea327cf09a325b5aa105274c45fb.tar.gz
gentoo-02c000a5dcffea327cf09a325b5aa105274c45fb.tar.bz2
gentoo-02c000a5dcffea327cf09a325b5aa105274c45fb.zip
xfce-base/xfce4-settings: Bump to 4.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.19.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index 2564fcece11d..c8e84fe560be 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1 +1,2 @@
DIST xfce4-settings-4.18.2.tar.bz2 1544572 BLAKE2B 8dee6855c98426aace796c7c6fe55770ca2c4c8e0c5129fd70274a0fe6589dd797eb078d79f7fd490c39cd4e1ec1dd90439c4cc030e7594aeb27c84e6e541fa2 SHA512 3371db3952f1863763b613952585873a0b8e1bd8507a64c056a918f3d16c3313e1266cb65dc341d3ce89ab281ee5a5d2cd183b6bb4078609b843524a125769b4
+DIST xfce4-settings-4.19.0.tar.bz2 2370986 BLAKE2B 64a25238afffb99fefe488d2218652ce714af7f783620ed5dc9d848911293bec25f95d81089cc9bb971f73e55a861c4953ebb9affd501eeb10f27a49dfc1b01b SHA512 8892d19f723bfacea1c7df8afa5abc7d45984f8b1070b24316cb8ca04ef621489632314ce1e361eda94e036df7a36b4a7988a7853469bbad1bde9e6bef9113d6
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.19.0.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.19.0.ebuild
new file mode 100644
index 000000000000..3e3368b8e3ae
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.19.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-settings/start
+ https://gitlab.xfce.org/xfce/xfce4-settings/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.66.0
+ >=media-libs/fontconfig-2.6.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libXcursor-1.1.0
+ >=x11-libs/libXi-1.2.0
+ >=x11-libs/libXrandr-1.2.0
+ >=xfce-base/garcon-0.1.10:=
+ >=xfce-base/exo-0.11.0:=
+ >=xfce-base/libxfce4ui-4.17.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.13.0:=
+ colord? ( >=x11-misc/colord-1.0.2:= )
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( >=x11-drivers/xf86-input-libinput-0.6.0 )
+ libnotify? ( >=x11-libs/libnotify-0.1.3 )
+ upower? ( >=sys-power/upower-0.9.8 )
+ xklavier? ( >=x11-libs/libxklavier-5.0 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+# libxml2 for xmllint
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable colord)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}