summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-04-25 10:02:58 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-04-26 09:04:08 +0200
commit02f907d8e8dc6f25a3a3a053da5c8fbdb405c9ad (patch)
tree79154c09f2f632560a945addb8933c82d06b7ea7
parentdev-lang/ruby: drop 3.0.5 (diff)
downloadgentoo-02f907d8e8dc6f25a3a3a053da5c8fbdb405c9ad.tar.gz
gentoo-02f907d8e8dc6f25a3a3a053da5c8fbdb405c9ad.tar.bz2
gentoo-02f907d8e8dc6f25a3a3a053da5c8fbdb405c9ad.zip
dev-tex/latexmk: add 480
Signed-off-by: Florian Schmaus <flow@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/30745 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-tex/latexmk/Manifest1
-rw-r--r--dev-tex/latexmk/latexmk-480.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-tex/latexmk/Manifest b/dev-tex/latexmk/Manifest
index c6aaf908e3df..95eaf509dad9 100644
--- a/dev-tex/latexmk/Manifest
+++ b/dev-tex/latexmk/Manifest
@@ -1 +1,2 @@
DIST latexmk-470b.zip 458908 BLAKE2B b82f09227412a05fcb662530b2c6691bac72640e5e1bc431de1710ca13b2c97f62f23fbf18a11eff21b222483367c7a4ba88cc197148d8f0b37edc53a96e1490 SHA512 2f984fd9c1785177fd58eb6bad44061bc7b397ed627599557704bae2cef1f53c186d161f99e4aaae5fa33fc66d56936dc9f5b6385f00d85bd634016bac0d555d
+DIST latexmk-480.zip 515014 BLAKE2B ec45e6590346c2ab0a226fff08143e5262fd442485c7199b3eea279901753b4d4d7c7d1030e44451a833bbfd74dcf04bae8fd6f63732ac4d5858f5dd96377687 SHA512 38652457a0ba311a7d4e3fdfeec53af27a1f370bf35e4f4214d97946eeece13b67ece22fe5b2c428c3d4d9145f593b683a1fc7993c11c601d8c4d87b592428da
diff --git a/dev-tex/latexmk/latexmk-480.ebuild b/dev-tex/latexmk/latexmk-480.ebuild
new file mode 100644
index 000000000000..b17c38a6c86d
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-480.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="https://personal.psu.edu/~jcc8/software/latexmk/
+ https://ctan.org/pkg/latexmk/"
+SRC_URI="https://personal.psu.edu/~jcc8/software/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}