summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-22 01:23:54 +0000
committerSam James <sam@gentoo.org>2022-11-22 01:33:09 +0000
commit0305ea926d6107adb5d9f432dca9614903481ce1 (patch)
tree86077dbc4b3d1b394ef7ffb6ddce9978196e57d7
parentnet-libs/libcloudproviders: Keyword 0.3.1 riscv, #879581 (diff)
downloadgentoo-0305ea926d6107adb5d9f432dca9614903481ce1.tar.gz
gentoo-0305ea926d6107adb5d9f432dca9614903481ce1.tar.bz2
gentoo-0305ea926d6107adb5d9f432dca9614903481ce1.zip
app-text/wgetpaste: add 2.33
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/wgetpaste/Manifest1
-rw-r--r--app-text/wgetpaste/files/wgetpaste-2.33-tests.patch83
-rw-r--r--app-text/wgetpaste/wgetpaste-2.33.ebuild38
3 files changed, 122 insertions, 0 deletions
diff --git a/app-text/wgetpaste/Manifest b/app-text/wgetpaste/Manifest
index ded79d65d8d0..15e185e5b013 100644
--- a/app-text/wgetpaste/Manifest
+++ b/app-text/wgetpaste/Manifest
@@ -1,3 +1,4 @@
DIST wgetpaste-2.29.tar.bz2 12988 BLAKE2B 838b84632754f6e07c25fe3648e14bf939dff4e08ae8e8064e94008beb436f77738e4f54859115321fbf445a323641ebfecf5fd7d09bbbb46c72e913687deb07 SHA512 6596842733bb5d1d52cbb3cbcf61ba714f0cbfdc13acb4d6025ccfd27c214adaf886ac3a0a11baefaa4af3f33165619e5a3360b4e0807d29e8dc8ef5ff819bb6
DIST wgetpaste-2.30_p20210222.tar.gz 14654 BLAKE2B e74332826f7faec3c2be2dddfd5f81d1ec14aec92888f27cdcd081b59262ac742003f2f48af3c3ca25be9e02f583a37dd1bec315236ab54912ebf6cf61308a10 SHA512 467daff5531fd6361ade87913ab867f67f72d5ffc07a35c263cd3dad65774ed31b3a6b0d69d2b52726a24419758d784c23e8c587f23e9028afd0e0a27966f32f
DIST wgetpaste-2.32.tar.gz 16626 BLAKE2B a8628a47edec5797f011fdf648cccf4147043bb699fe6ebfc38b66d1bbff1840147613e1de1a2abf1048b83247e9a16026bed4174be605f99e59035cf7c64f9f SHA512 57f6194c864adf3eabffe46163d1c83a5c2c30affc4c353fee5cafe6aaf19cfa306e134cb5dd216577eb34cc93eee66b28297e5a1d4fa92d78d38597170d40bb
+DIST wgetpaste-2.33.tar.xz 16408 BLAKE2B 78baebf4edb6e6340a73127099366d306359d02c0c1eab137822c56669da0609a5479940b4fb2accbc79978df091dcd34415876618e64aa556d1584f74773736 SHA512 9bf1f379316da372b4f69296b54f9a266dcf9fdaa2a8718165a2029571f4c2c0166304ffebeb2ec4657ea6f49087793f40d9da383f5da052bce0543c90ea13ab
diff --git a/app-text/wgetpaste/files/wgetpaste-2.33-tests.patch b/app-text/wgetpaste/files/wgetpaste-2.33-tests.patch
new file mode 100644
index 000000000000..41d0bece7962
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-2.33-tests.patch
@@ -0,0 +1,83 @@
+https://github.com/zlin/wgetpaste/pull/38
+
+From 3470bbe651c2264a7f985f3b86f67a6ff6d0c587 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 22 Nov 2022 01:29:16 +0000
+Subject: [PATCH 1/3] test: respect TMPDIR in mktemp (pass --tmpdir)
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/test/test.sh
++++ b/test/test.sh
+@@ -7,7 +7,7 @@
+ # Don't assume the test is being run from the same directory as the script
+ TEST_DIR="$(dirname "$0")"
+ TEST_FILE="$TEST_DIR/test.txt"
+-DL_DIR="$(mktemp -q -d /tmp/wgetpaste_test.XXXXX)"
++DL_DIR="$(mktemp -q --tmpdir -d wgetpaste_test.XXXXX)"
+ # Services to hard skip
+ # Pre-declare as map to maintain type even if empty
+ # key -> value := service -> reason
+--- a/test/test_ansi.sh
++++ b/test/test_ansi.sh
+@@ -9,7 +9,7 @@
+ TEST_DIR="$(dirname "$0")"
+ ANSI_FILE="$TEST_DIR/red.txt"
+ NOANSI_FILE="$TEST_DIR/red_no_ansi.txt"
+-DL_DIR="$(mktemp -q -d /tmp/wgetpaste_test_ansi.XXXXX)"
++DL_DIR="$(mktemp -q --tmpdir -d wgetpaste_test_ansi.XXXXX)"
+ # Services to hard skip
+ # Pre-declare as map to maintain type even if empty
+ # key -> value := service -> reason
+
+From 0c3cc1a5286c95a5bcd6408035f6c230350c1565 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 22 Nov 2022 01:29:40 +0000
+Subject: [PATCH 2/3] test: use portable bash shebang
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/test/test.sh
++++ b/test/test.sh
+@@ -1,4 +1,4 @@
+-#! /bin/bash
++#!/usr/bin/env bash
+
+ # wgetpaste test script
+ # Exit code: number of mismatched downloads or 1 for general failure
+--- a/test/test_ansi.sh
++++ b/test/test_ansi.sh
+@@ -1,4 +1,4 @@
+-#! /bin/bash
++#!/usr/bin/env bash
+
+ # wgetpaste test script (stripping ANSI codes)
+ # Based on test/test.sh
+
+From 8d1cf7a8d0ce9ff21a8e1dc66169b04e4f8fc852 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 22 Nov 2022 01:29:55 +0000
+Subject: [PATCH 3/3] test: normalise copyright header
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/test/test.sh
++++ b/test/test.sh
+@@ -2,7 +2,7 @@
+
+ # wgetpaste test script
+ # Exit code: number of mismatched downloads or 1 for general failure
+-# Copyright (C) 2021 xxc3nsoredxx
++# Copyright (C) 2022 Oskari Pirhonen <xxc3ncoredxx@gmail.com>
+
+ # Don't assume the test is being run from the same directory as the script
+ TEST_DIR="$(dirname "$0")"
+--- a/test/test_ansi.sh
++++ b/test/test_ansi.sh
+@@ -3,7 +3,7 @@
+ # wgetpaste test script (stripping ANSI codes)
+ # Based on test/test.sh
+ # Exit code: number of mismatched downloads or 1 for general failure
+-# Copyright (C) 2022 Oskari Pirhonen <xxc3ncoredxx@gmail.com>
++# Copyright (C) 2022 Oskari Pirhonen <xxc3ncoredxx@gmail.com>
+
+ # Don't assume the test is being run from the same directory as the script
+ TEST_DIR="$(dirname "$0")"
+
diff --git a/app-text/wgetpaste/wgetpaste-2.33.ebuild b/app-text/wgetpaste/wgetpaste-2.33.ebuild
new file mode 100644
index 000000000000..f6662506f9ae
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.33.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="https://wgetpaste.zlin.dk/"
+SRC_URI="https://github.com/zlin/wgetpaste/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+ssl"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="net-misc/wget[ssl?]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.33-tests.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+}
+
+src_test() {
+ test/test.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}