summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-30 15:26:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-30 15:29:53 +0000
commit032309d72f75e765256a3988367ed7eeaef9ffa9 (patch)
treec892d7b506b50c1bc9266f0239af1ad815e95a09
parentdev-python/m2r: Bump (diff)
downloadgentoo-032309d7.tar.gz
gentoo-032309d7.tar.bz2
gentoo-032309d7.zip
dev-python/pyasn1: Bump
Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--dev-python/pyasn1/Manifest1
-rw-r--r--dev-python/pyasn1/pyasn1-0.3.6.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyasn1/Manifest b/dev-python/pyasn1/Manifest
index df0ecb4c9fd6..1f262944f32c 100644
--- a/dev-python/pyasn1/Manifest
+++ b/dev-python/pyasn1/Manifest
@@ -1,2 +1,3 @@
DIST pyasn1-0.1.8.tar.gz 75676 SHA256 5d33be7ca0ec5997d76d29ea4c33b65c00c0231407fff975199d7f40530b8347 SHA512 0a0b9b8018ae80a0e0d84ea3a4f217951bf42dce909a354c97890d4b4fc4f49b19d9d0757103ac9002c17c6c622c8e8d66e1f8242b8545a7da455ef3583acdfa WHIRLPOOL db46e06ef9a6b5858c07f1c154657f998b509c457395b4f2e6286ea90e1b16346e24d92a8d666b5db4216e35129f2d6be13c2fc11aae2d9936163bff3b1400eb
DIST pyasn1-0.2.3.tar.gz 100099 SHA256 66c70011074ed6f5a74591591a9f0bed4bc2c2a45baef60f8dcc89ab5da11b9d SHA512 c55b95c1995f2fc36ec28f35837ca456a2fac06e90edc6491a3335ae949e4eacbbeb14f6289a17e994b49d4dc60870bba3e79344c44496d5547c38ab1ef183ab WHIRLPOOL d74142002096d49914e8b15a425764a08c02a43326b9ca1511f4e316fd025c0ce9333c748e010794fe788416b38aa7a1e3460c346524200ba4bd3836297d405c
+DIST pyasn1-0.3.6.tar.gz 117506 SHA256 3a263cea3e15f459b1e97b1f7d3840b890eeb29eddaf480203a2929a651c5968 SHA512 0857b957bd29f999858869e02ee84ec86aae6362229da14b47f4c54f1358632d161e417325e0e2cec8a3fa293f52156d703481dac872e7f323e317cf14197dce WHIRLPOOL 84fe36d176482ea296e9434ae17faf6b1bc58667fb7102855e51c8427da81777e80ad3306e50d35ef95b03f15460ff1cf38c83e5adbe436f5588778a023f57f7
diff --git a/dev-python/pyasn1/pyasn1-0.3.6.ebuild b/dev-python/pyasn1/pyasn1-0.3.6.ebuild
new file mode 100644
index 000000000000..386b3f4ad63b
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.3.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1"
+SRC_URI="https://github.com/etingof/pyasn1/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# The required doc/source/conf.py file is missing from the pypi:
+# https://github.com/etingof/pyasn1/issues/35
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test || die "Tests fail with ${EPYTHON}"
+}
+
+src_compile() {
+ if use doc; then
+ python_setup
+ esetup.py build_sphinx
+ fi
+ distutils-r1_src_compile
+}
+
+src_install() {
+ local HTML_DOCS
+ use doc && HTML_DOCS=( build/sphinx/html/. )
+
+ distutils-r1_src_install
+}