summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 04:45:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 05:21:36 +0200
commit032619699a091f8a7bed24fc3a335c3f87c3c4b7 (patch)
treea615284eb475426cdedc379b8341b0fc5a6d27c4
parentdev-python/botocore: Bump to 1.34.106 (diff)
downloadgentoo-032619699a091f8a7bed24fc3a335c3f87c3c4b7.tar.gz
gentoo-032619699a091f8a7bed24fc3a335c3f87c3c4b7.tar.bz2
gentoo-032619699a091f8a7bed24fc3a335c3f87c3c4b7.zip
dev-python/boto3: Bump to 1.34.106
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.106.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a394bf7fccb6..6ee62d9196b9 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,5 +1,6 @@
DIST boto3-1.34.103.gh.tar.gz 807394 BLAKE2B da291c86a8b20bcaac5f93779899bfa5c6ce207499df393cd921f37021c1c38ed0587edd2261cee8de7ce17264670f9cda072d6748f274e6f3d9b40caa499803 SHA512 3b879f88a145ca7ea7533e4d8aa77cec351f272c59fa119622dab061fd6354f88d33709bd1621802f38f19e8378505caa94b8a6b561d16f4a2aa168828021206
DIST boto3-1.34.104.gh.tar.gz 807605 BLAKE2B d315be19b5d54b74d2cec2967fb4d12bb2c3529f404dd41628d1fe41de7b0f81fa28b098268ea020db4334b863c875e7cf31763a179352b3f3bc6326a33d2f56 SHA512 18fb51400a20686db02317812da15dd6117a630896ed284b6fece7c7903265a2e9d5d74a8d5fe0eb504ed2e27d1b714369a4391a095f771aaf09609745436cdf
DIST boto3-1.34.105.gh.tar.gz 807800 BLAKE2B a61b420b89fc153de0a32b5212eb5c492d2576fbad06073dfed5960bc15e6d45fa06df20ef59b9a41c4a9295a4129ff43f7781828d6f76ba7ba86a53bc5b6ee4 SHA512 d35ce5780f73ee973a232345f2585d4aff3f477c2976eb3127285ab7a143c94de19e4997036e65cbc3cc9e987d36b26ce2d028fb0e8f34e6813f5d5d65666fea
+DIST boto3-1.34.106.gh.tar.gz 808363 BLAKE2B 4dcfdd6b7d3f143abc1296b87209c3bba12c38e07df5d019e080e8cd1ea3cf2916a6fca3c0bcbc1321c312432020e24f2d851e5371a53f46995830f39f2c132f SHA512 6aea22407bb58d6c7a177402005b31d3a303a780b6379d3614e7ac508f582b11a6a726ce88f02ec57a0e1998ad8da1c6fceaa3f8b6ccfa5a1410a1e9b50b6fda
DIST boto3-1.34.93.gh.tar.gz 802078 BLAKE2B 43f19efd6ae42bdb20e8dd79b1735df229ec2f231b5fe05006b26fcd5ddf4796a53fba6011c298fb919ee7b205b4ae3f4b563ad3b5325bdbbdebaeab7be59608 SHA512 4da1d9d7d8648e895f23763e5055a868d05bbfd8eb28d56e716975b3b8349bd1825d703f6fd11c316174004c39e1fca5ddcd8a4ad27a000e1a52f08a36eb4780
DIST boto3-1.34.98.gh.tar.gz 805719 BLAKE2B 5cf7f0cc415e25c8b41aa464b636b1683f4e71198569f5eac3e6e43cef7050e20e92c3fd988517fc1463601073b41b0b9c668a58bb866d03b83973c9b9cd976a SHA512 06cab81bbf73a9c37b68e0312a7c587bace700b8032e283b6782c1275804ea7c93065c4282837957b5cf3523d50fe57319a54af494262e2666f65440da9771fd
diff --git a/dev-python/boto3/boto3-1.34.106.ebuild b/dev-python/boto3/boto3-1.34.106.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.106.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}