summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-28 10:39:49 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-28 10:40:34 +0200
commit03342c0437f6bd506165fb5edcef68769a55f137 (patch)
tree786232604255e5c2cffb911f2e92af6749d7ad13
parentdev-lang/eisl: bump to 2.96 (diff)
downloadgentoo-03342c0437f6bd506165fb5edcef68769a55f137.tar.gz
gentoo-03342c0437f6bd506165fb5edcef68769a55f137.tar.bz2
gentoo-03342c0437f6bd506165fb5edcef68769a55f137.zip
games-util/cartridges: new package; add 1.5.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-util/cartridges/Manifest1
-rw-r--r--games-util/cartridges/cartridges-1.5.4.ebuild51
-rw-r--r--games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch10
-rw-r--r--games-util/cartridges/metadata.xml20
4 files changed, 82 insertions, 0 deletions
diff --git a/games-util/cartridges/Manifest b/games-util/cartridges/Manifest
new file mode 100644
index 000000000000..925544d6bd02
--- /dev/null
+++ b/games-util/cartridges/Manifest
@@ -0,0 +1 @@
+DIST cartridges-1.5.4.tar.gz 1302013 BLAKE2B f54d867ce769c843ee8114ea2946618a1ee275dff877a5f5b175f2457d5f67ffe412b188d44961aaa351acfd8e89e68d9b30442f79d747ebba7fd8432fa82d45 SHA512 b69b18150ecec2dc39ab126f1708f04af4902babdd999b5d26d71b001e8111f062ef6edc4efed66b551b2a84b7bed1e18a4e3aecf3f60aaa3518c08e144a8a25
diff --git a/games-util/cartridges/cartridges-1.5.4.ebuild b/games-util/cartridges/cartridges-1.5.4.ebuild
new file mode 100644
index 000000000000..aa27bde5c236
--- /dev/null
+++ b/games-util/cartridges/cartridges-1.5.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Chirurgien helps to understand and manipulate file formats"
+HOMEPAGE="https://github.com/kra-mo/cartridges/"
+SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.4-dont-validate-appstream.patch )
+
+src_install() {
+ meson_src_install
+
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize "${ED}"/usr/share/cartridges/cartridges
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}
diff --git a/games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch b/games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch
new file mode 100644
index 000000000000..7cfc09376292
--- /dev/null
+++ b/games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch
@@ -0,0 +1,10 @@
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -54,7 +54,6 @@ appstream_file = i18n.merge_file(
+
+ appstream_util = find_program('appstream-util', required: false)
+ if appstream_util.found()
+- test('Validate appstream file', appstream_util, args: ['validate', appstream_file])
+ endif
+
+ install_data(
diff --git a/games-util/cartridges/metadata.xml b/games-util/cartridges/metadata.xml
new file mode 100644
index 000000000000..703d77d0fd2e
--- /dev/null
+++ b/games-util/cartridges/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Cartridges is a simple game launcher for all of your games. It has support
+ for importing games from Steam, Lutris, Heroic and more with no login
+ necessary. You can sort and hide games or download cover art from
+ SteamGridDB.
+ </longdescription>
+ <upstream>
+ <changelog>https://github.com/kra-mo/cartridges/releases/</changelog>
+ <bugs-to>https://github.com/kra-mo/cartridges/issues/</bugs-to>
+ <remote-id type="github">kra-mo/cartridges</remote-id>
+ </upstream>
+</pkgmetadata>