summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Hamann <code@ares-macrotechnology.com>2020-08-10 20:05:50 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-24 17:38:45 +0300
commit0338258449e3bd125f50ea3244c043efc3801dec (patch)
treee1099c6b4a8692bf9695c64eb07021edae5af535
parentapp-admin/passwordsafe: version bump to 1.11.0 (diff)
downloadgentoo-0338258449e3bd125f50ea3244c043efc3801dec.tar.gz
gentoo-0338258449e3bd125f50ea3244c043efc3801dec.tar.bz2
gentoo-0338258449e3bd125f50ea3244c043efc3801dec.zip
sys-auth/yubico-piv-tool: Bump to version 2.1.1
Closes: https://bugs.gentoo.org/732000 Signed-off-by: Sebastian Hamann <code@ares-macrotechnology.com> Closes: https://github.com/gentoo/gentoo/pull/17072 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-auth/yubico-piv-tool/Manifest1
-rw-r--r--sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-install-man-page.patch29
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild38
3 files changed, 68 insertions, 0 deletions
diff --git a/sys-auth/yubico-piv-tool/Manifest b/sys-auth/yubico-piv-tool/Manifest
index 4b8764da7677..ab6a0967e1c0 100644
--- a/sys-auth/yubico-piv-tool/Manifest
+++ b/sys-auth/yubico-piv-tool/Manifest
@@ -1 +1,2 @@
DIST yubico-piv-tool-1.6.2.tar.gz 182957 BLAKE2B 0ca9bdcda68f7ee100078604854caccc5141ab01e40f894ae36c3175afa3989c1d0074ef0994e1e369d67499a9778e22f0c5a3cf930d1ba162b0ee0ddbc05f91 SHA512 fc72b9d381f10b63c8958b6c90c1ee97e3ef6b5fb283a9513e6f2ace972710c2872903f38350d9e4a3576b16cb0890b067dd55f5c125f443d353df3f628a9f96
+DIST yubico-piv-tool-2.1.1.tar.gz 1302573 BLAKE2B da4419b7074930f7d264f21a12973511d350e687d0487b93d25a528f4a79d5df44dbbdde34ef7cd0d14507ba1a00f776fcd7eaf503f2253d8ee8da3e9a68010f SHA512 14d880088f7624f600c6badb6504c4c71ef29ff82e9c29bd837013e62273c6b198ca581705cc7fb9f3c0c13334767ea7b340fb033ce99fb60fb0478281affc9f
diff --git a/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-install-man-page.patch b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-install-man-page.patch
new file mode 100644
index 000000000000..1d782767b3aa
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/files/yubico-piv-tool-2.1.1-install-man-page.patch
@@ -0,0 +1,29 @@
+From e635608785ed374bfe5f1158ca4a4695f3ea2f08 Mon Sep 17 00:00:00 2001
+From: Dan Church <amphetamachine@gmail.com>
+Date: Fri, 5 Jun 2020 11:09:30 -0500
+Subject: [PATCH] Fix omission of man page
+
+It was omitting the man page upon first install, so in order to get the
+man page added to the installed set of files, one would have to run
+cmake, then run make, then run cmake again, then run make.
+
+Also clarify when the extra `install` step would be added.
+---
+ tool/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tool/CMakeLists.txt b/tool/CMakeLists.txt
+index c12a474..03efefe 100644
+--- a/tool/CMakeLists.txt
++++ b/tool/CMakeLists.txt
+@@ -66,8 +66,10 @@ if (GENERATE_MAN_PAGES)
+ add_help2man_manpage (yubico-piv-tool.1 yubico-piv-tool)
+
+ add_custom_target (yubico-piv-tool-man ALL DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/yubico-piv-tool.1)
++ install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/yubico-piv-tool.1" DESTINATION "${YKPIV_INSTALL_MAN_DIR}/man1")
+ endif(GENERATE_MAN_PAGES)
+
++# If somehow a manpage was generated before configure started, install that too
+ find_file(MAN_PAGE yubico-piv-tool.1 PATHS ${CMAKE_CURRENT_SOURCE_DIR})
+ if(MAN_PAGE)
+ install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/yubico-piv-tool.1" DESTINATION "${YKPIV_INSTALL_MAN_DIR}/man1")
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild
new file mode 100644
index 000000000000..e61b928b9a35
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Command line tool for the YubiKey PIV application"
+SRC_URI="https://github.com/Yubico/yubico-piv-tool/archive/yubico-piv-tool-${PV}.tar.gz"
+HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
+
+LICENSE="BSD-2"
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=[-bindist]
+ sys-apps/pcsc-lite
+"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+PATCHES=("${FILESDIR}/${P}-install-man-page.patch")
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIB=OFF
+ )
+ cmake_src_configure
+}