summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-06 19:34:08 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-06 21:12:24 -0500
commit033e74310d71ffcc872fc341fb45059aa6e046df (patch)
tree478ad76d095452742602d743fc8290a19788b65f
parentsys-apps/net-tools: version bump to 2.10 (diff)
downloadgentoo-033e7431.tar.gz
gentoo-033e7431.tar.bz2
gentoo-033e7431.zip
x11-libs/vte: Version bump to 0.62.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/vte/Manifest2
-rw-r--r--x11-libs/vte/vte-0.62.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
index b2c6da103380..c43019f99ac7 100644
--- a/x11-libs/vte/Manifest
+++ b/x11-libs/vte/Manifest
@@ -1,3 +1,5 @@
DIST vte-0.28.2.tar.xz 962340 BLAKE2B 1e4b5977962265be77917ccfc9118ed93232c03d7a16b6c08a27e721fe71f8c1dd1783a439530d7b3d915111cb8cc78281f1e9e351d6a83edd31f224309ca1e9 SHA512 d6a50481aaa8946cca3779e0b328fef551be534d70366a75385d1f8ead3fcddec57bed85c7d4bc2d9f34546532129e63083aafa33cbb0efcbc7dc9d66e7c45f6
DIST vte-0.60.3-command-notify.patch.xz 6108 BLAKE2B 1f96788c097b003a3f9041529a0ff8ad083fe60597920632450e65ce13ad7181cb3bd4f2713ee19ab7d15154e3546720cdd0a72fabb3710ea7149c63cb159a1f SHA512 070d17fa2dfeed5ccb5ad67687bfb65a6a9dd79db300bb6e00f7d35b8ab3563c331e5f48bbecc32f8037475db319fb71f35e72108f260b6446fd2dd8e1a2897e
DIST vte-0.60.3.tar.xz 535504 BLAKE2B c5556fdb91d876aa681d2a9466fa4f4c0ee6be630d076949fbd01878baffdf319e50ec75575729c49c09484914d9ee103d4d491861aedb678b0e336cd4ddcc2e SHA512 3694fe711e0b3eb9d6ba37ad8036f5d3cca4265635ed7afcde750a8445b17f820d1c55b557d0ea1c8a5a45e5408915d8da2ffd65b4d397c6582f288812ae1f18
+DIST vte-0.62.1-command-notify.patch.xz 4844 BLAKE2B 22301fdc5f1969beb2ad9b316fea8972f696f0e54e1a24d5eceedec71162afc2991b7963a71ce8925a94f6c40e5303d3db760b872d0eebbdc6d05b22d3c59ecc SHA512 491e241b0f5aae50e59d25751e95579d40c47e7e4c7f2b279522347f7f2f7f00c92bdf5fa4a651e4146bcfa9439f03b6311b4061fb20c5679c09b97a4924dcf1
+DIST vte-0.62.1.tar.xz 444672 BLAKE2B 83cf49c8700792a149d572bae692d4909ada613b43a752b55cb658926dc37041b98d69364a88f813b1cc6d20f0667ea566f994e0f08bd1dd918731d20edb1376 SHA512 2f8f76953e0ea6c604357ab08630d3822a252051d8997cf7714553fec1688735468726bfd74e03f122dd1c8d0717e511ec7ec1e5463a086bd407afc6f7df91cf
diff --git a/x11-libs/vte/vte-0.62.1.ebuild b/x11-libs/vte/vte-0.62.1.ebuild
new file mode 100644
index 000000000000..80301a89aacd
--- /dev/null
+++ b/x11-libs/vte/vte-0.62.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.32"
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91"
+IUSE="+crypt debug gtk-doc +icu +introspection systemd +vala vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+REQUIRED_USE="vala? ( introspection )"
+
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-0.62.1-command-notify.patch.xz )"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.24.14:3[introspection?]
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.52:2
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ icu? ( dev-libs/icu:= )
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ x11-libs/pango[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ if ! use vanilla; then
+ # Part of https://src.fedoraproject.org/rpms/vte291/raw/f31/f/vte291-cntnr-precmd-preexec-scroll.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${PN}-0.62.1-command-notify.patch
+ fi
+
+ # -Ddebugg option enables various debug support via VTE_DEBUG, but also ggdb3; strip the latter
+ sed -e '/ggdb3/d' -i meson.build || die
+
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=true
+ $(meson_use debug debugg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dfribidi=true # pulled in by pango anyhow
+ $(meson_use crypt gnutls)
+ -Dgtk3=true
+ -Dgtk4=false
+ $(meson_use icu)
+ $(meson_use systemd _systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${ED}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}