summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-23 03:51:47 +0100
committerSam James <sam@gentoo.org>2022-08-23 03:51:47 +0100
commit034c6401e819d26eaee589598141bf9233fc41db (patch)
tree54cc91d606b7bc98f3a025e7f9d7da7eec72c3a2
parentx11-base/xorg-server: Stabilize 21.1.4 hppa, #858140 (diff)
downloadgentoo-034c6401.tar.gz
gentoo-034c6401.tar.bz2
gentoo-034c6401.zip
sys-apps/ethtool: add 5.19
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-5.19.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index c51d14ff6424..7d5fd537e08c 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -4,3 +4,4 @@ DIST ethtool-5.15.tar.xz 318864 BLAKE2B 855c07e388bfabf37637f20e2714c6ca27717f38
DIST ethtool-5.16.tar.xz 320308 BLAKE2B 198d76502510e533b7f51785fd9f0848e840a6b4237bfd0496d005978ce3e638be02bd7dee971501f57c83354a1ac2f34a7ef29f2255764e900d9299bad9254c SHA512 9f0c24323b3144cbc6e684dc8c545a7c5e4804a061f10e32c937ea7420cc25c0891137fd4be4f1b9cf44907d8a59970ead9db424051ec5b4a90c225038f04025
DIST ethtool-5.17.tar.xz 321848 BLAKE2B 1695077d812b3ed8e287615d6a3aa15525a061110fa63563e4b2db3e5d4718b023415508db63e857c572fef248c6797564da596f17c80b833839899656840a5d SHA512 c9677829e3ed1f373bd993f72c710293a6e987bbd19829d437a436f42cf4e7995ee70a7db3590b1499ff6aa29c26815f4d0a3e4798ffb6992ae3f52b079cd3ff
DIST ethtool-5.18.tar.xz 322600 BLAKE2B 5c06c74ac1453b66fa3f2a01a3face8c6483bdd6849a0b258f5a3d0c041712de4d628240843d09a54e69ec6256dfaac5fa3b08d5e1d2033b2810a01f9be04673 SHA512 bd53e64d5cfe0fe4c3fbc9ec84e64f77b72d0229bbb611575007fd1e4c5c13611440b292edc875f1916707477e1d1e19b8f46785285d6b88066e9b9aafba9753
+DIST ethtool-5.19.tar.xz 324472 BLAKE2B 44cc292db04f411a57a0a5ae0cdfbef733c7ee739fc252523c713489a13ae33de3927b500db796bc584fef3c83d7238dca2af4e6b6a5c594bbf21e87ed2380a7 SHA512 71103c6856a889161ef2bf81eadec69b2f3a84c94aa776d545f889dc1c55b91d566d3b7394dbd2cb70ed92ac19d5f26967b1f829c204f23831d1fb81a0464972
diff --git a/sys-apps/ethtool/ethtool-5.19.ebuild b/sys-apps/ethtool/ethtool-5.19.ebuild
new file mode 100644
index 000000000000..8d122a733c09
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.19.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}