summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-12 15:42:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-12 16:33:15 +0100
commit03595614784c11bc743e1fdeb92a008acad50b12 (patch)
treeb5becba3e4a0447ac9e5d30f041ccdfd511d07b6
parentdev-python/rapidfuzz: Bump to 2.13.6 (diff)
downloadgentoo-03595614784c11bc743e1fdeb92a008acad50b12.tar.gz
gentoo-03595614784c11bc743e1fdeb92a008acad50b12.tar.bz2
gentoo-03595614784c11bc743e1fdeb92a008acad50b12.zip
dev-python/pycares: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-4.3.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index 158a830f15a8..45194e72ba8c 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1 +1,2 @@
DIST pycares-4.2.2.gh.tar.gz 44200 BLAKE2B a857f20f0f1cf0243f02d7f8663bfba3d0f97f033afb5eee5ec3ff74b70279cb3535c04953c3131771a1a6447032e309dbed064a4e85b30980361f5db3d674f1 SHA512 1a6b30e8f55d37ca0af9dfd70fd3a0630b691f5f76b4f650e9c98c585b26bd1ff9c237fc1705ce5dc257857db0dce2f020f12099f0c211f5ad0f12196f39433b
+DIST pycares-4.3.0.gh.tar.gz 44577 BLAKE2B b69eeb34a2f8c9d7025dc74881431b3fc5489b7f7e9142bb9ecdaf217e495ad72b1a6a7dc484a52e6a01394bbfa6d0609b2054dd4a663176cfb73d980642a3e1 SHA512 1dad1a6722bdd2bc59cc4ca774cc9da243e61a442ef383c238714b1274e90359352c72d16a2c1af2fcce3ea92708a7e5cee89a9b3eb7c015f9a194051c685f52
diff --git a/dev-python/pycares/pycares-4.3.0.ebuild b/dev-python/pycares/pycares-4.3.0.ebuild
new file mode 100644
index 000000000000..35eb0d0b9602
--- /dev/null
+++ b/dev-python/pycares/pycares-4.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="
+ https://github.com/saghul/pycares/
+ https://pypi.org/project/pycares/
+"
+SRC_URI="
+ https://github.com/saghul/pycares/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/pycares-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ net-dns/c-ares:=
+"
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}
+"
+BDEPEND+="
+ test? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+export PYCARES_USE_SYSTEM_LIB=1