summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-09-02 18:37:46 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-09-02 18:38:04 +0200
commit036190f796c1c116c28ca5bbc827def27eae2acb (patch)
treeea8ab73f06562505c9e6b5fdf8c5620cbdfaa8e8
parentnet-vpn/openconnect: support python 3.8 and 3.9 (diff)
downloadgentoo-036190f796c.tar.gz
gentoo-036190f796c.tar.bz2
gentoo-036190f796c.zip
app-vim/pydoc: add python3_7 and python3_8 to PYTHON_TARGETS.
Closes: https://bugs.gentoo.org/737358 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-vim/pydoc/pydoc-2.0-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/pydoc/pydoc-2.0-r2.ebuild b/app-vim/pydoc/pydoc-2.0-r2.ebuild
new file mode 100644
index 000000000000..3105dd0dc42a
--- /dev/null
+++ b/app-vim/pydoc/pydoc-2.0-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: integrates python documentation view and search tool"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=910 https://github.com/fs111/pydoc.vim"
+SRC_URI="https://github.com/fs111/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"