summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2019-08-23 16:52:34 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2019-08-23 16:56:57 +0200
commit0385ac994786119ca0d166b59e0fc8c4fa446208 (patch)
tree8e05223fb9b9b60d4b6d4da321d3fa20869cbb7d
parentprofiles: Mask www-apps/{groupoffice,phpwebsite,sitebar} for removal (diff)
downloadgentoo-0385ac99.tar.gz
gentoo-0385ac99.tar.bz2
gentoo-0385ac99.zip
sys-devel/parity: support x64; no more legacy MSVC by default
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
-rw-r--r--sys-devel/parity/metadata.xml1
-rw-r--r--sys-devel/parity/parity-9999.ebuild12
2 files changed, 10 insertions, 3 deletions
diff --git a/sys-devel/parity/metadata.xml b/sys-devel/parity/metadata.xml
index f6466ef21aa1..b5ae82a3cc83 100644
--- a/sys-devel/parity/metadata.xml
+++ b/sys-devel/parity/metadata.xml
@@ -19,6 +19,7 @@
<flag name="vc14_0">Enable support for Visual Studio 2015</flag>
<flag name="vc15_0">Enable support for Visual Studio 2017</flag>
<flag name="vc16_2">Enable support for Visual Studio 2019</flag>
+ <flag name="vc_x64">Enable support for 64bit Visual Studio compilers</flag>
<flag name="vc_x86">Enable support for 32bit Visual Studio compilers</flag>
</use>
</pkgmetadata>
diff --git a/sys-devel/parity/parity-9999.ebuild b/sys-devel/parity/parity-9999.ebuild
index 38577c8f86b1..50ab4b1e491e 100644
--- a/sys-devel/parity/parity-9999.ebuild
+++ b/sys-devel/parity/parity-9999.ebuild
@@ -14,14 +14,20 @@ fi
DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
HOMEPAGE="https://github.com/haubi/parity"
-parity-vcarchs() { echo x86 ; }
-parity-vcvers() { echo 7_0 7_1 8_0 9_0 10_0 11_0 12_0 14_0 15_0 16_2 ; }
+parity-vcarchs() { echo x64 x86 ; }
+parity-vcvers-legacy() { echo 7_0 7_1 8_0 9_0 ; }
+parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15_0 16_2 ; }
+parity-vcvers() {
+ parity-vcvers-legacy
+ parity-vcvers-current
+}
LICENSE="LGPL-3"
SLOT="0"
IUSE="$(
for a in $(parity-vcarchs); do echo "+vc_${a}"; done
- for v in $(parity-vcvers); do echo "+vc${v}"; done
+ for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
+ for v in $(parity-vcvers-current); do echo "+vc${v}"; done
)"
if [[ ${PV} == 9999 ]]; then