summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-17 15:07:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-17 15:07:58 +0200
commit03a89df55a0073d62659a16f1a18c6da50708d61 (patch)
treeef5358a043ce1b5ed81ecdef236afdf347886548
parentdev-python/rosdistro: eapi update and bump to 0.6.9 (diff)
downloadgentoo-03a89df5.tar.gz
gentoo-03a89df5.tar.bz2
gentoo-03a89df5.zip
dev-python/rospkg: eapi update and bump to 1.1.7
Package-Manager: Portage-2.3.46, Repoman-2.3.10
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.1.7.ebuild48
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild7
3 files changed, 54 insertions, 2 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index c61dc8ce14bd..55489bb818ee 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1 +1,2 @@
DIST rospkg-1.1.4.tar.gz 89554 BLAKE2B b307482cc3df0f2a178dd427a37160cfdc3c407b2135a28854f3df0ff964ed57c17a8ee358a1aa90b3d735e0913bc6c3c8ea1084efdef5fd01933166e21ebac8 SHA512 1758dcbe28c18c834a60bbda2e5e6be34629b3dd4f6519f24dfa1324ff9fc59fb7d0ae9d324c002eee06ff672309627e48f97119b36601390b24a24ae196d5c5
+DIST rospkg-1.1.7.tar.gz 90200 BLAKE2B 5b64be62b292ed8d216058d9e906451c74ebfecced92da2888b6e6340a217f56460b9dad6fb741a1b78c156513adfb435407dfac19a9fcbca49b180662b879a2 SHA512 7d6915a32370786384220cd0d62087e0f82648e96f2006853dfb1486ff5b6c3343e32b9ac8a33ad1c1a8c758499475553b081166ca7ee0c72659855a2b09f151
diff --git a/dev-python/rospkg/rospkg-1.1.7.ebuild b/dev-python/rospkg/rospkg-1.1.7.ebuild
new file mode 100644
index 000000000000..c59845d0d461
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index bf7619313e02..c59845d0d461 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
@@ -30,10 +30,13 @@ SLOT="0"
IUSE="test"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)