summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-29 12:51:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-29 13:02:54 +0200
commit03b47b4d56d8cfa4f8694d3ee491af7db5426bfa (patch)
treed2769a33cb63826f89631662a4dda55cc03d3a3a
parentwww-client/seamonkey: Removed old (diff)
downloadgentoo-03b47b4d56d8cfa4f8694d3ee491af7db5426bfa.tar.gz
gentoo-03b47b4d56d8cfa4f8694d3ee491af7db5426bfa.tar.bz2
gentoo-03b47b4d56d8cfa4f8694d3ee491af7db5426bfa.zip
dev-python/pytest-timeout: Add missing test-dep on pexpect
Closes: https://bugs.gentoo.org/719998 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild
index 1fe275fe5426..8f63704bdd23 100644
--- a/dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild
+++ b/dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild
@@ -15,8 +15,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )"
python_test() {
distutils_install_for_testing