summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 16:13:00 +0200
committerSam James <sam@gentoo.org>2022-06-29 17:49:22 +0000
commit03c214b859b37ba9fa4d414be50967489a8d6363 (patch)
tree0d245506a03611273a0461d3136ae94a8f3d39cf
parentdistutils-r1.eclass: Print gpep517 invocations verbosely (diff)
downloadgentoo-03c214b8.tar.gz
gentoo-03c214b8.tar.bz2
gentoo-03c214b8.zip
distutils-r1.eclass: Adjust minimal dep versions to current stable
Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--eclass/distutils-r1.eclass48
1 files changed, 30 insertions, 18 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ba21e3c43d92..85d6c8ae5080 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -205,27 +205,33 @@ _distutils_set_globals() {
fi
bdep='
- >=dev-python/gpep517-3[${PYTHON_USEDEP}]'
+ >=dev-python/gpep517-6[${PYTHON_USEDEP}]
+ '
case ${DISTUTILS_USE_PEP517} in
flit)
bdep+='
- >=dev-python/flit_core-3.7.1[${PYTHON_USEDEP}]'
+ >=dev-python/flit_core-3.7.1[${PYTHON_USEDEP}]
+ '
;;
flit_scm)
bdep+='
- dev-python/flit_scm[${PYTHON_USEDEP}]'
+ dev-python/flit_scm[${PYTHON_USEDEP}]
+ '
;;
hatchling)
bdep+='
- >=dev-python/hatchling-0.22.0[${PYTHON_USEDEP}]'
+ >=dev-python/hatchling-1.3.1[${PYTHON_USEDEP}]
+ '
;;
jupyter)
bdep+='
- >=dev-python/jupyter_packaging-0.11.1[${PYTHON_USEDEP}]'
+ >=dev-python/jupyter_packaging-0.12.0-r1[${PYTHON_USEDEP}]
+ '
;;
maturin)
bdep+='
- >=dev-util/maturin-0.12.7[${PYTHON_USEDEP}]'
+ >=dev-util/maturin-0.12.17[${PYTHON_USEDEP}]
+ '
;;
no)
# undo the generic deps added above
@@ -233,28 +239,34 @@ _distutils_set_globals() {
;;
meson-python)
bdep+='
- dev-python/meson-python[${PYTHON_USEDEP}]'
+ dev-python/meson-python[${PYTHON_USEDEP}]
+ '
;;
pbr)
bdep+='
- >=dev-python/pbr-5.8.0-r1[${PYTHON_USEDEP}]'
+ >=dev-python/pbr-5.8.0-r1[${PYTHON_USEDEP}]
+ '
;;
pdm)
bdep+='
- >=dev-python/pdm-pep517-0.12.3[${PYTHON_USEDEP}]'
+ >=dev-python/pdm-pep517-1.0.0[${PYTHON_USEDEP}]
+ '
;;
poetry)
bdep+='
- >=dev-python/poetry-core-1.0.8[${PYTHON_USEDEP}]'
+ >=dev-python/poetry-core-1.0.8[${PYTHON_USEDEP}]
+ '
;;
setuptools)
bdep+='
- >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]'
+ >=dev-python/setuptools-62.3.3[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ '
;;
sip)
bdep+='
- >=dev-python/sip-6.5.0-r1[${PYTHON_USEDEP}]'
+ >=dev-python/sip-6.5.0-r1[${PYTHON_USEDEP}]
+ '
;;
standalone)
;;
@@ -473,7 +485,7 @@ distutils_enable_sphinx() {
_DISTUTILS_SPHINX_PLUGINS=( "${@}" )
local deps autodoc=1 d
- deps=">=dev-python/sphinx-4.4.0[\${PYTHON_USEDEP}]"
+ deps=">=dev-python/sphinx-4.5.0-r1[\${PYTHON_USEDEP}]"
for d; do
if [[ ${d} == --no-autodoc ]]; then
autodoc=
@@ -497,7 +509,7 @@ distutils_enable_sphinx() {
use doc || return 0
local p
- for p in ">=dev-python/sphinx-4.4.0" \
+ for p in ">=dev-python/sphinx-4.5.0-r1" \
"${_DISTUTILS_SPHINX_PLUGINS[@]}"
do
python_has_version "${p}[${PYTHON_USEDEP}]" ||
@@ -505,7 +517,7 @@ distutils_enable_sphinx() {
done
}
else
- deps=">=dev-python/sphinx-4.4.0"
+ deps=">=dev-python/sphinx-4.5.0-r1"
fi
sphinx_compile_all() {
@@ -585,10 +597,10 @@ distutils_enable_tests() {
local test_pkg
case ${1} in
nose)
- test_pkg=">=dev-python/nose-1.3.7-r4"
+ test_pkg=">=dev-python/nose-1.3.7_p20211111_p1-r1"
;;
pytest)
- test_pkg=">=dev-python/pytest-7.0.1"
+ test_pkg=">=dev-python/pytest-7.1.2"
;;
setup.py)
;;