summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-07 06:47:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-07 08:06:36 +0100
commit03c30b56d7c9d6b1a98c2a952fb0a1d1dbc44f54 (patch)
tree6dae08beaa214bc66b5e967cb36bbc273f7b970a
parentdev-python/fonttools: Revert "add pypy3 to PYTHON_COMPAT" (diff)
downloadgentoo-03c30b56d7c9d6b1a98c2a952fb0a1d1dbc44f54.tar.gz
gentoo-03c30b56d7c9d6b1a98c2a952fb0a1d1dbc44f54.tar.bz2
gentoo-03c30b56d7c9d6b1a98c2a952fb0a1d1dbc44f54.zip
dev-python/jupyterlab-server: Bump to 2.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index ac441b956356..4a919968f631 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1 +1,2 @@
DIST jupyterlab_server-2.19.0.tar.gz 69979 BLAKE2B f44eea3aa2a19c0f2e548b33e1677a8daf4b6098bfb682f3ebae816d38c6cd24769aea35053f2a9e656e5b2bba2a032d4bd75ba976d30238fa4d27c9a1a69867 SHA512 058a1663ca1d6663be9de1243b178637a61e2ff156ca00163d9f30301d8527ca26235f1d3183bc2b48b6b4b82dbea595a4c7f0a989736b603851f5d78f8da078
+DIST jupyterlab_server-2.20.0.tar.gz 70481 BLAKE2B 188b8a9bd2bfc5a27ce6f8488d7768484fd71ae8bb93f28c8a49f63b1aef13551c55d7e18531830df26617883f6b780a491d3522a0dcb3ecddcc433cfb35f97b SHA512 7d9a86f56686344ffc1ad11a9fc7c736a2ac0e6b8c31f8b6d8e35e5fd982454b2362073038dfc2ed3a4f03ef53e2afcaa33fc2c956b63e44c3d1ae6efa1f9251
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild
new file mode 100644
index 000000000000..6280fed7052a
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter_server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.17[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}