summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 09:52:32 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 09:52:32 +0100
commit03c3faa03bcde18a805811b7b311ef26efe14826 (patch)
treede97fa2fd593338234ce66638f9e6a9f4e7825d5
parentsys-devel/lld: Delay llvm.org_set_globals after vars (diff)
downloadgentoo-03c3faa0.tar.gz
gentoo-03c3faa0.tar.bz2
gentoo-03c3faa0.zip
sys-devel/clang-common: Delay llvm.org_set_globals after vars
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang-common/clang-common-11.0.0.9999.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-12.0.0.9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
index 18e41e0917da..1c9ca4dbe647 100644
--- a/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-11.0.0.9999.ebuild
@@ -7,8 +7,6 @@ inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
-llvm.org_set_globals
S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
@@ -18,6 +16,9 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+
src_install() {
newbashcomp bash-autocomplete.sh clang
}
diff --git a/sys-devel/clang-common/clang-common-12.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-12.0.0.9999.ebuild
index 18e41e0917da..1c9ca4dbe647 100644
--- a/sys-devel/clang-common/clang-common-12.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-12.0.0.9999.ebuild
@@ -7,8 +7,6 @@ inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
-llvm.org_set_globals
S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
@@ -18,6 +16,9 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+
src_install() {
newbashcomp bash-autocomplete.sh clang
}