summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 06:03:47 +0100
committerSam James <sam@gentoo.org>2022-05-31 06:03:51 +0100
commit03c6ce6635813240331b8c154bb55a407396a58d (patch)
tree0c843676a4c1745c5eb958e8ef4e248ca9b8d608
parentprofiles: remove references to 'ayatana' USE flag (diff)
downloadgentoo-03c6ce6635813240331b8c154bb55a407396a58d.tar.gz
gentoo-03c6ce6635813240331b8c154bb55a407396a58d.tar.bz2
gentoo-03c6ce6635813240331b8c154bb55a407396a58d.zip
media-video/pitivi: add missing libpeas dep, fixup setuptools dep
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-video/pitivi/files/pitivi-2021.05-python-collections.patch13
-rw-r--r--media-video/pitivi/pitivi-2021.05-r1.ebuild (renamed from media-video/pitivi/pitivi-2021.05.ebuild)10
2 files changed, 21 insertions, 2 deletions
diff --git a/media-video/pitivi/files/pitivi-2021.05-python-collections.patch b/media-video/pitivi/files/pitivi-2021.05-python-collections.patch
new file mode 100644
index 000000000000..fc04cd8d8726
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-2021.05-python-collections.patch
@@ -0,0 +1,13 @@
+https://src.fedoraproject.org/rpms/pitivi/raw/rawhide/f/collections.patch
+--- a/pitivi/utils/loggable.py
++++ b/pitivi/utils/loggable.py
+@@ -14,7 +14,7 @@
+ #
+ # You should have received a copy of the GNU Lesser General Public
+ # License along with this program; if not, see <http://www.gnu.org/licenses/>.
+-import collections
++import collections.abc as collections
+ import errno
+ import fnmatch
+ import os
+
diff --git a/media-video/pitivi/pitivi-2021.05.ebuild b/media-video/pitivi/pitivi-2021.05-r1.ebuild
index e5a66ed35143..a52f0b5b2206 100644
--- a/media-video/pitivi/pitivi-2021.05.ebuild
+++ b/media-video/pitivi/pitivi-2021.05-r1.ebuild
@@ -8,7 +8,7 @@ PYTHON_REQ_USE="sqlite"
inherit gnome.org meson python-single-r1 xdg
DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
-HOMEPAGE="http://www.pitivi.org"
+HOMEPAGE="https://www.pitivi.org"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -34,6 +34,9 @@ RDEPEND="${COMMON_DEPEND}
>=dev-libs/glib-2.30.0:2
>=dev-libs/gobject-introspection-1.34:=
+
+ dev-libs/libpeas[${PYTHON_SINGLE_USEDEP}]
+
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
>=dev-python/gst-python-1.4:1.0[${PYTHON_USEDEP}]
@@ -59,7 +62,9 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${RDEPEND}"
BDEPEND="
app-text/yelp-tools
- dev-python/setuptools
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
>=dev-util/intltool-0.35.5
dev-util/itstool
sys-devel/gettext
@@ -69,6 +74,7 @@ BDEPEND="
PATCHES=(
# https://gitlab.gnome.org/GNOME/pitivi/-/commit/ddf2369d1fc6fddd63f676cc905a8b8e96291a4c
"${FILESDIR}"/${P}-meson-compatibility.patch
+ "${FILESDIR}"/${P}-python-collections.patch
)
src_configure() {