summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-04 10:43:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-04 17:54:07 +0200
commit03e09ac68a85f54a4140fb025d61fef3e1f31755 (patch)
tree9973cf888159d75d578f66dc9530658c8c1eef8b
parentkde-misc/kdeconnect: Drop 20.08.1 (r0) (diff)
downloadgentoo-03e09ac68a85f54a4140fb025d61fef3e1f31755.tar.gz
gentoo-03e09ac68a85f54a4140fb025d61fef3e1f31755.tar.bz2
gentoo-03e09ac68a85f54a4140fb025d61fef3e1f31755.zip
kde-apps/ark: Cleanup vulnerable 20.04.3-r1
Bug: https://bugs.gentoo.org/743959 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/ark/ark-20.04.3-r1.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/kde-apps/ark/ark-20.04.3-r1.ebuild b/kde-apps/ark/ark-20.04.3-r1.ebuild
deleted file mode 100644
index a06c99dee9c..00000000000
--- a/kde-apps/ark/ark-20.04.3-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="forceoptional"
-ECM_TEST="optional"
-KFMIN=5.70.0
-QTMIN=5.14.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="KDE Archiving tool"
-HOMEPAGE="https://kde.org/applications/utilities/org.kde.ark
-https://utils.kde.org/projects/ark/"
-
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE="bzip2 lzma zip"
-
-BDEPEND="
- sys-devel/gettext
-"
-RDEPEND="
- app-arch/libarchive:=[bzip2?,lzma?,zlib]
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=kde-frameworks/karchive-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemmodels-${KFMIN}:5
- >=kde-frameworks/kjobwidgets-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kpty-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- sys-libs/zlib
- zip? ( >=dev-libs/libzip-1.2.0:= )
-"
-DEPEND="${RDEPEND}
- >=dev-qt/qtconcurrent-${QTMIN}:5
-"
-
-# bug #560548, last checked with 16.04.1
-RESTRICT+=" test"
-
-PATCHES=( "${FILESDIR}/${P}-CVE-2020-16116.patch" )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package bzip2 BZip2)
- $(cmake_use_find_package lzma LibLZMA)
- $(cmake_use_find_package zip LibZip)
- )
-
- ecm_src_configure
-}
-
-pkg_postinst() {
- ecm_pkg_postinst
-
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- if ! has_version app-arch/rar; then
- elog "For creating/extracting rar archives, installing app-arch/rar is required."
- if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
- elog "Alternatively, for only extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
- fi
- fi
-
- has_version app-arch/p7zip || \
- elog "For handling 7-Zip archives, install app-arch/p7zip."
-
- has_version app-arch/lrzip || \
- elog "For handling lrz archives, install app-arch/lrzip."
- fi
-}