summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-12-19 10:37:50 +0100
committerPacho Ramos <pacho@gentoo.org>2022-12-19 10:37:50 +0100
commit03e90ad50d7575387a4a6fe1c00d23e334b5b689 (patch)
treee3779ab9c7f2b428f8ea225fa0a446007e30a362
parentx11-libs/libwnck: Fix crashes on xfce and segfault (diff)
downloadgentoo-03e90ad50d7575387a4a6fe1c00d23e334b5b689.tar.gz
gentoo-03e90ad50d7575387a4a6fe1c00d23e334b5b689.tar.bz2
gentoo-03e90ad50d7575387a4a6fe1c00d23e334b5b689.zip
dev-libs/ayatana-ido: new package, add 0.9.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-libs/ayatana-ido/Manifest1
-rw-r--r--dev-libs/ayatana-ido/ayatana-ido-0.9.2.ebuild45
-rw-r--r--dev-libs/ayatana-ido/metadata.xml10
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/ayatana-ido/Manifest b/dev-libs/ayatana-ido/Manifest
new file mode 100644
index 000000000000..e738118b3beb
--- /dev/null
+++ b/dev-libs/ayatana-ido/Manifest
@@ -0,0 +1 @@
+DIST ayatana-ido-0.9.2.tar.gz 122286 BLAKE2B f6498591d72fa6deb5d9c8d87ddad399e41b3701719e45fe82dc8d5bd6ede30bb754561fdeaa938713692a90b8c48657ea2cb472c762acab6c3f36c73907b92e SHA512 efc5825d32d707b02397692c347f99f3bca13da2cd653b6ce87882643c85c2698bdac6168e89a01ed98d5ee58c88a820d89dad7b88a5aee235b450c40969d0a7
diff --git a/dev-libs/ayatana-ido/ayatana-ido-0.9.2.ebuild b/dev-libs/ayatana-ido/ayatana-ido-0.9.2.ebuild
new file mode 100644
index 000000000000..45c5daadf28e
--- /dev/null
+++ b/dev-libs/ayatana-ido/ayatana-ido-0.9.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+VALA_USE_DEPEND="vapigen"
+
+inherit cmake vala
+
+DESCRIPTION="Ayatana Application Indicators (Shared Library)"
+HOMEPAGE="https://github.com/AyatanaIndicators/ayatana-ido"
+SRC_URI="https://github.com/AyatanaIndicators/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3 GPL-3"
+SLOT="0"
+IUSE="test"
+
+# https://github.com/AyatanaIndicators/ayatana-ido/issues/62
+RESTRICT="test"
+#RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.58:2
+ >=x11-libs/gtk+-3.24:3[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ test? ( dev-cpp/gtest )
+"
+
+src_prepare() {
+ cmake_src_prepare
+ vala_setup
+}
+
+src_configure() {
+ local mycmakeargs+=(
+ -DVALA_COMPILER="${VALAC}"
+ -DVAPI_GEN="${VAPIGEN}"
+ -DENABLE_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/ayatana-ido/metadata.xml b/dev-libs/ayatana-ido/metadata.xml
new file mode 100644
index 000000000000..fee410960338
--- /dev/null
+++ b/dev-libs/ayatana-ido/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AyatanaIndicators/ayatana-ido</remote-id>
+ </upstream>
+</pkgmetadata>