summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-30 05:16:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-30 06:26:51 +0200
commit03eb65a5b95b900aaf24772f5d8d4046ea8f177e (patch)
tree12e1241a89d4585978d1c5e0b489a46404055431
parentmedia-sound/cadence: remove unused patch (diff)
downloadgentoo-03eb65a5.tar.gz
gentoo-03eb65a5.tar.bz2
gentoo-03eb65a5.zip
dev-python/botocore: Bump to 1.27.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.20.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 14d3df4b0be5..049bca4ffd9b 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,4 +6,5 @@ DIST botocore-1.27.16.tar.gz 9138117 BLAKE2B ed636cd031445b14f57282326836616dca6
DIST botocore-1.27.17.tar.gz 9130505 BLAKE2B 04c6b37f3b42a0f9fb696b5213338b004418a68c754f5027ad447119fb20556dc49bd53f40fd9560ea3f5bdcf2afbe151dba68e901079baec770f9f223b1a894 SHA512 b1a145d3c97adfd4df40639da99e1c34087508be189d5818ee7176f20454f2897a6f518a14b4bfbf41cb169a17188bec467337c10d0ad511e223f0c1ff5b64ee
DIST botocore-1.27.18.tar.gz 9129942 BLAKE2B 61c06ec3ec8350cb9c43c5716faabe5035b74907fd4a94f9b007ec6e488ffb38a9d75d5b3372fcbbd26cb7f9599ba185cbcf2fb48f7e5900e0028832bef74187 SHA512 9eb700af06b1eca88df77ad46a54a73bbd198d36b055ea219c8948557bda7edd0307f48321c416c3128fe2baacc35aaea10f31c57b43511a512c6c7c46b0a6db
DIST botocore-1.27.19.tar.gz 9132910 BLAKE2B a23d64ec934de03f7c31b1c89229d5054e689fd050a74db7467b31c79c38eb732286d4db747ca132fa9917be79abcac27b3423f9d0a0e9c9477f56c2ace3944e SHA512 28ab3d94c8f3763b42bd36c97787ce8f86bd8958cfc1b63fd445713fcea523ed1be615a699d0476a3fa8798eff791791c6a466845b63d1454a6aeee6bf9425a6
+DIST botocore-1.27.20.tar.gz 9146126 BLAKE2B 3ec9e6480fb5bc95f72ffa1f0972b7d9e807fce2e69a3118818a7eba5c1023316c9499bdcbc2f6b2616842eb8797ed0b2bef5ebceee5b74a12074b927b339994 SHA512 1ac0b189e14fb25f07c63e4933113ca64c2bdc53fe719270daccc55b2c7d8ba7421fa81aa60e6fc3a0c86cdb3f57980781388586ce154d87f17f860cc943467a
DIST botocore-1.27.7.tar.gz 9102259 BLAKE2B 094ec463531f1dfd54ff32d0f44ebc39cdc0a6d4c3e19b49a25e25d9d13acdcd26c782c1d4819ea4f1cb8954a858aa6e997411785678700b7ca03cd8844527b5 SHA512 d4a1327f4314279548af00fbc6da2f9fc5f25f704da3f6ddfa90773878f28ac9f03556b00fa4c0207ec2e952eb716aa98c1c22abffbd51d82dc55d9e4ceeca5c
diff --git a/dev-python/botocore/botocore-1.27.20.ebuild b/dev-python/botocore/botocore-1.27.20.ebuild
new file mode 100644
index 000000000000..830c713f6036
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.20.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}