summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-17 23:10:15 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-17 23:15:35 -0400
commit0406e5611e86c504279fa1521e479b0da7b1e7bf (patch)
treeb79bb3541199ffcc16c9f66153d678649dfbe750
parentdev-python/pygobject: Version bump to 3.40.1 (diff)
downloadgentoo-0406e561.tar.gz
gentoo-0406e561.tar.bz2
gentoo-0406e561.zip
games-board/iagno: Version bump to 3.38.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--games-board/iagno/Manifest1
-rw-r--r--games-board/iagno/iagno-3.38.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/games-board/iagno/Manifest b/games-board/iagno/Manifest
index 80c4e2dd1a80..ff36470f6d94 100644
--- a/games-board/iagno/Manifest
+++ b/games-board/iagno/Manifest
@@ -1 +1,2 @@
DIST iagno-3.36.4.tar.xz 799480 BLAKE2B 430aa403c974728b929a7715e783dd594f00300dd9b0bf8b6f84da7265e31536a5cae17db94bcbdbebe3ef2690cb05bf18292af158016ec18bb695e58ca20f3d SHA512 43775149f76904a19316e5eac990d8dae0a730c3f6798ad88648892d4795b6892a86fb93b78a72fd30853ad36cc5e4b241e1cbd4067c78d6648f1630543f87be
+DIST iagno-3.38.1.tar.xz 766188 BLAKE2B 1265a9b3480bdf2ed949af9fd1e8eb0a8aa996a267d9e0e7c4300232ed857a5ef37fca9942b5bb50606e1fa9bc7058660d11296443d5a90213f76d2fbeb83cd1 SHA512 d36e445c01487a79df6fb6b1b77991118a978716688cf166d593656e1f8dbc3f872d0e739145b9ea9629563457d441918d7f46241d29edae8bdf74f54174d4f1
diff --git a/games-board/iagno/iagno-3.38.1.ebuild b/games-board/iagno/iagno-3.38.1.ebuild
new file mode 100644
index 000000000000..4950b4bec7ad
--- /dev/null
+++ b/games-board/iagno/iagno-3.38.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.44"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Dominate the board in a classic version of Reversi"
+HOMEPAGE="https://wiki.gnome.org/Apps/Reversi"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.24.0:3
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}"
+# libxml2:2 needed for glib-compile-resources xml-stripblanks attributes
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+ gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}