summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-03-29 14:04:25 +1100
committerSam Jorna <wraeth@gentoo.org>2016-03-29 14:04:52 +1100
commit040c652e26d71a12c0df295626edce9d3a5baec0 (patch)
treeb87fbcb86fbd572dddbe637109a152f867496fc0
parentgames-action/extreme-tuxracer: version bump (bug #578406) (diff)
downloadgentoo-040c652e.tar.gz
gentoo-040c652e.tar.bz2
gentoo-040c652e.zip
net-misc/capi4hylafax: bump to 01.03.00.99.300.20
Version bump to 01.03.00.99.300.20, includes patch to resolve compile failure with newer versions of GCC (patch included in source). Ebuild originally submitted by user Matthias Jansen. Gentoo-bug: 513642 Package-Manager: portage-2.2.28
-rw-r--r--net-misc/capi4hylafax/Manifest1
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20.ebuild155
2 files changed, 156 insertions, 0 deletions
diff --git a/net-misc/capi4hylafax/Manifest b/net-misc/capi4hylafax/Manifest
index d0582c33b00e..019c7593550f 100644
--- a/net-misc/capi4hylafax/Manifest
+++ b/net-misc/capi4hylafax/Manifest
@@ -1,3 +1,4 @@
+DIST capi4hylafax_01.03.00.99.svn.300-20.debian.tar.gz 546271 SHA256 783d31e3ae73df91607e86856ff93338eaf2c84f9b31ad21106005e479232f4c SHA512 a0c1e64d783150abf80feecca07a3eebead95a982133ac9601b204b73933468c61fa39863be8c93ea2bf52c5262b9944b4d5c4a8795475d3a5ca17e481401b8e WHIRLPOOL 25e9d37697fdf0bbde5bb84bfeea37ac749bdfca5da8b75b5474e39c3684efdd9ff517773bc0d77641331a5bdb9c500dc0caf7dfec84733fb200e1a5c7e1bf92
DIST capi4hylafax_01.03.00.99.svn.300-3.diff.gz 155360 SHA256 dec167255e2307d12b5093e11ddbb6b1f96d0ac94985643579cfd6b534313ed2 SHA512 abf963a8840d9baf18ea7985f2354a287daaec3192eb54e9a5fd1ea838fd493f7ec3ad6399aa4e21256ff3bd6801a3511c031afb43e3160526d9bfe4d24f065a WHIRLPOOL e5f5832e96794fd8233b7e7e9e393026033e3c9b55b2757890ee8fbde08591e0f526f986327904f46a45ec5c592b7e61061e796fbc20e9f07c2ddbd6a337946b
DIST capi4hylafax_01.03.00.99.svn.300-9.diff.gz 160179 SHA256 5c116fcefa6604a351c31507644c26fb43e0dc89e51f97ee748a52a5eebbc4af SHA512 3f98a69b96bb44cec4976cad954e52586b50bce1f8457391c1a07ca22689c9687779311252c87848b779c9afac0d492eefca11a270de551a7cacfce50d1aa185 WHIRLPOOL db79395c01935734c679345e2010882393a41dc1f7edb3af2ce1b993cca4ff61ad753b33071ea8cc5b4b85281ccfcd63f09758188665decc02c4f08856536251
DIST capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410 SHA256 8c5433fda85d5f178382c0a4fbc07cf22fc22c448146a4b7a090bc6a0b1789c2 SHA512 c01063bcdf7d5dfbeef0eadd94a0714b5f34f442c19e5287a0fa40ce3ecbbad53afaddeb093435952367fb7b503dd9c637002d954a58175df3920d9d2966c468 WHIRLPOOL 1fafcf1f88fe02f7b4b0bca0b4c40d1917d5fb1f02a11bd67aeebe46e049fcadecde78f8c6b7626c4bb4f23a3bdbec86a3e013e383ccf202cae407842ec0ae29
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20.ebuild
new file mode 100644
index 000000000000..d4f049fe6cfe
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.20.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils versionator autotools
+
+FAX_SPOOL_DIR="${ROOT}/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment"
+SRC_URI="mirror://debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.debian.tar.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-dialup/capi4k-utils
+ app-shells/bash:0
+ media-libs/tiff:0
+ virtual/jpeg:0
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+DOCS=( AUTHORS ChangeLog Readme_src )
+HTML_DOCS=( README.html LIESMICH.html )
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/debian/patches" EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" epatch
+
+ eapply_user
+
+ eautoreconf
+
+ mv ../debian . || die
+
+ # fix location of fax spool
+ sed -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" \
+ -i config.faxCAPI \
+ -i Readme_src \
+ -i src/defaults.h.in \
+ -i debian/*.1 || die
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile || die
+
+ # fix name and location of logfile
+ sed -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" \
+ -i config.faxCAPI || die
+
+ sed -e "s:/tmp/capifax.log:/var/log/${PN}.log:" \
+ -i src/defaults.h.in config.faxCAPI || die
+
+ # patch man pages
+ sed -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" \
+ -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" \
+ -i debian/*.1 || die
+
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8 || die
+}
+
+src_configure() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ default
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ newdoc debian/changelog ChangeLog.debian
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ elog "To use capi4hylafax:"
+ elog "Make sure that your isdn/capi devices are owned by"
+ elog "the \"uucp\" user (see udev or devfsd config)."
+ elog "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ elog "to suit your system."
+
+ if [ -n "${REPLACING_VERSIONS}" ]; then
+ elog
+ elog "If you're upgrading from a previous version"
+ elog "please check for new or changed options."
+ elog "A sample default config is installed as:"
+ elog "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ elog
+ elog "Please run package config to install a default configuration."
+ fi
+
+ elog
+ elog "You should also check special options in:"
+ elog "/etc/conf.d/${PN}"
+ elog
+ elog "The following optional dependency is also available:"
+ optfeature "hylafax integration" net-misc/hylafax
+ elog
+ elog "Then append the following line to your hylafax"
+ elog "config file (${FAX_SPOOL_DIR}/etc/config):"
+ elog "SendFaxCmd: /usr/bin/c2faxsend"
+ einfo
+}
+
+pkg_config() {
+ local config_file="${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ if [ -e "${config_file}" ]; then
+ eerror "The configuration file already exists. Please either update"
+ eerror "or remove this file and re-run package configuration."
+ eerror "Configuration file location: ${config_file}"
+ else
+ elog "Installing template configuration file to ${config_file}"
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${config_file}" || die
+ fi
+}