summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-29 14:10:25 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-07 15:36:36 +0100
commit0421a583fbde0b37162cb755788d37fa1399c6b1 (patch)
treea013ea7b78bf3dfdc31b4a2759e96acd23e0fd0b
parentdistutils-r1.eclass: Depend on setuptools by default (diff)
downloadgentoo-0421a583fbde0b37162cb755788d37fa1399c6b1.tar.gz
gentoo-0421a583fbde0b37162cb755788d37fa1399c6b1.tar.bz2
gentoo-0421a583fbde0b37162cb755788d37fa1399c6b1.zip
dev-python/setuptools: Disable setuptools self-dependency
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/setuptools-40.6.3.ebuild1
-rw-r--r--dev-python/setuptools/setuptools-41.5.1.ebuild1
-rw-r--r--dev-python/setuptools/setuptools-42.0.0.ebuild1
-rw-r--r--dev-python/setuptools/setuptools-42.0.1.ebuild1
-rw-r--r--dev-python/setuptools/setuptools-9999.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/setuptools/setuptools-40.6.3.ebuild b/dev-python/setuptools/setuptools-40.6.3.ebuild
index d5d482efd58e..a21883a89f89 100644
--- a/dev-python/setuptools/setuptools-40.6.3.ebuild
+++ b/dev-python/setuptools/setuptools-40.6.3.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
PYTHON_REQ_USE="xml(+)"
diff --git a/dev-python/setuptools/setuptools-41.5.1.ebuild b/dev-python/setuptools/setuptools-41.5.1.ebuild
index ff4a7aa54630..a7b9022b6a0c 100644
--- a/dev-python/setuptools/setuptools-41.5.1.ebuild
+++ b/dev-python/setuptools/setuptools-41.5.1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
PYTHON_REQ_USE="xml(+)"
diff --git a/dev-python/setuptools/setuptools-42.0.0.ebuild b/dev-python/setuptools/setuptools-42.0.0.ebuild
index e7aa7c945a85..8c33401e75bd 100644
--- a/dev-python/setuptools/setuptools-42.0.0.ebuild
+++ b/dev-python/setuptools/setuptools-42.0.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
PYTHON_REQ_USE="xml(+)"
diff --git a/dev-python/setuptools/setuptools-42.0.1.ebuild b/dev-python/setuptools/setuptools-42.0.1.ebuild
index 0c293d1ea950..58369bab16cb 100644
--- a/dev-python/setuptools/setuptools-42.0.1.ebuild
+++ b/dev-python/setuptools/setuptools-42.0.1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
PYTHON_REQ_USE="xml(+)"
diff --git a/dev-python/setuptools/setuptools-9999.ebuild b/dev-python/setuptools/setuptools-9999.ebuild
index 8d522c4213f5..34b0627c0728 100644
--- a/dev-python/setuptools/setuptools-9999.ebuild
+++ b/dev-python/setuptools/setuptools-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
PYTHON_REQ_USE="xml(+)"