summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-30 22:44:38 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-30 22:44:38 +0200
commit0422e4e59f88311c980af48fff4ac7e0be396bc3 (patch)
treeeac9587aafe43a86c290742e84f9ed0440e4c717
parentdev-db/mongodb: drop 4.2.17-r2, 4.2.23 (diff)
downloadgentoo-0422e4e5.tar.gz
gentoo-0422e4e5.tar.bz2
gentoo-0422e4e5.zip
dev-python/jaraco-test: add 5.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jaraco-test/Manifest1
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.2.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 1372386c1643..0f460dbc2328 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1 +1,2 @@
DIST jaraco.test-5.1.0.tar.gz 6700 BLAKE2B 69ac08ab7e1c8aeff45d25483f2bb2648ad57a5977dbff8aab844f114a15f054b782ad5b424d9baa805ab80fc7483362dc97320965ef0abe86573b1e7f40b97b SHA512 d1d93eab85068fcba94530df50da9221b7f574e58b2c4ed519c8c4dec7231aa982d588e29137418226f23e0f94bd98f47c0859cf14d7a58c1683ac8ccc24d900
+DIST jaraco.test-5.2.0.tar.gz 8000 BLAKE2B 21e0714537a9966cc285eb1458f313c354226903ee3da816d7a6620676716cf9c220f82963c8b8ea7ac7a1d641f174d5c72dcca43c68c62e4f929c411aa00d62 SHA512 25cd7d5defda6941569958ce61cf41b54555d54c7dc1e115de409d6da352f8e8c09b8671adbdfdc00cf6f1c60a0d43201680c40dbeda44bdcf11a0e64cb23751
diff --git a/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild
new file mode 100644
index 000000000000..8b5ed987f9b2
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest