summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 11:41:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 11:49:26 +0200
commit044a2d023583678f96b4996e06e319b10d55b8b7 (patch)
treeb51110dbd67ccb8ad14e1eb39582585e281bc789
parentdev-python/geventhttpclient: Remove old (diff)
downloadgentoo-044a2d023583678f96b4996e06e319b10d55b8b7.tar.gz
gentoo-044a2d023583678f96b4996e06e319b10d55b8b7.tar.bz2
gentoo-044a2d023583678f96b4996e06e319b10d55b8b7.zip
dev-python/psycopg: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-3.0.16.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 1b7090047e0d..56c0dc9b8dd9 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,4 +1,3 @@
-DIST psycopg-3.0.16.gh.tar.gz 386693 BLAKE2B c6c0bd9832e65180e7de76b04ef7c81f4c2d0981894d090b933ce0efaaafdf6b62d1d71a4c70c7c9b848b67e576a71953116925f9e991a4ed99b53067e24cbba SHA512 655e01bb00972dacae590f2e8ce5948226acb827b55099e7f362fdee9210f07b755f4da10d2fadd468aa95eaa3f72e7658a1ab26870d4ac159ee266ce1f8140c
DIST psycopg-3.1.1.gh.tar.gz 464501 BLAKE2B 1796ae830051ee0719e4723036ca672ac005793beb88da21b9775cdc96dd4f58b3d008eb3f3a87c3f7293ea097480bbe72a8591b68371d1f7c7261c37927e40f SHA512 a243626c5e0ee0ef414c193b9168f58ec6fa3bfc5652c25c3c1f355f4cea29bcc993ba631a125c0a0335155c15fc068f6cfa5e8974de0cd32e007ae6d3db23dc
DIST psycopg-3.1.2.gh.tar.gz 467017 BLAKE2B 5e13156ff05a356bb59ebae77e8ad3d3e35ab669a43102fa7751927e0ecfbebd1b30db7d62bd0865f426c2e6362a98a6d9cad19c9001abf29b6d030b4dd0204b SHA512 3e412ec91a337012086b1260527b2179883f6b44a26c5e8437c92351ca39594c4430f251abdfbc52e4b2c69d5e91ba09883578b177e836691cd295b6e8464fdf
DIST psycopg-3.1.gh.tar.gz 463892 BLAKE2B 94100bed4807771f6c4d0469737b160955f3f6bfcff84240c9e15dd9b7b88765583952b712642740c97f6ec42223edcf74fb2c5390a185f44ca0eb8858e76100 SHA512 057a14d614ccb9f36a7db7a82c3d48953658a1c6af2a2265a93a3f6c1db421275e51e1be4d59e2ea98b638f3da8c24c9d2a4d9aabf6190c47691dd632c9339f9
diff --git a/dev-python/psycopg/psycopg-3.0.16.ebuild b/dev-python/psycopg/psycopg-3.0.16.ebuild
deleted file mode 100644
index a3964c006ce6..000000000000
--- a/dev-python/psycopg/psycopg-3.0.16.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="
- https://www.psycopg.org/psycopg3/
- https://github.com/psycopg/psycopg/
- https://pypi.org/project/psycopg/
-"
-SRC_URI="
- https://github.com/psycopg/psycopg/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S=${WORKDIR}/${P}/psycopg
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-
-DEPEND="
- >=dev-db/postgresql-8.1:*
-"
-RDEPEND="
- ${DEPEND}
- $(python_gen_cond_dep '
- >=dev-python/backports-zoneinfo-0.2.0[${PYTHON_USEDEP}]
- ' 3.8)
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
- ' 3.8 3.9)
-"
-BDEPEND="
- test? (
- >=dev-db/postgresql-8.1[server]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # tests for the psycopg_pool package
- tests/pool
- # some broken mypy magic
- tests/test_module.py::test_version
- tests/test_module.py::test_version_c
- tests/test_typing.py
- # TODO, relying on undefined ordering in Python?
- tests/test_dns_srv.py::test_srv
-)
-
-src_test() {
- # tests are lurking in top-level directory
- cd .. || die
-
- initdb -D "${T}"/pgsql || die
- # TODO: random port
- pg_ctl -w -D "${T}"/pgsql start \
- -o "-h '' -k '${T}'" || die
- createdb -h "${T}" test || die
-
- local -x PSYCOPG_TEST_DSN="host=${T} dbname=test"
- distutils-r1_src_test
-
- pg_ctl -w -D "${T}"/pgsql stop || die
-}