summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-28 15:21:10 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-28 15:28:02 +0200
commit045112a9203516f7ce889cb9d76f44e0f3658193 (patch)
tree81190f38a495198afb9e30337df6ac765c825d5e
parentnet-proxy/3proxy: respect CC (diff)
downloadgentoo-045112a9203516f7ce889cb9d76f44e0f3658193.tar.gz
gentoo-045112a9203516f7ce889cb9d76f44e0f3658193.tar.bz2
gentoo-045112a9203516f7ce889cb9d76f44e0f3658193.zip
app-emulation/e-uae: Remove last-rited pkg
Closes: https://bugs.gentoo.org/602966 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-emulation/e-uae/Manifest1
-rw-r--r--app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild157
-rw-r--r--app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch18
-rw-r--r--app-emulation/e-uae/files/e-uae-0.8.29_rc4-no_schily.patch20
-rw-r--r--app-emulation/e-uae/files/e-uae-0.8.29_rc4-tinfo.patch22
-rw-r--r--app-emulation/e-uae/metadata.xml14
-rw-r--r--profiles/package.mask3
7 files changed, 1 insertions, 234 deletions
diff --git a/app-emulation/e-uae/Manifest b/app-emulation/e-uae/Manifest
deleted file mode 100644
index 18008f168831..000000000000
--- a/app-emulation/e-uae/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST e-uae-0.8.29-WIP4.tar.bz2 1122718 BLAKE2B 4120e7d14e4ee1a8be04839680c30dc57286524a68eb8036a8f48a0724c3581884045c2ad11bb8409a88b2f43bd132b92083e1e1cc088c5b4768f3b6dfdef458 SHA512 63d5c60ca017ba7ffaba32c4d7edceba0410b773066cc58e226c8cc2c92152eb3689698b0affe478cc63c996c731fbbf56d9028dfd000394d904f193f860473f
diff --git a/app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild b/app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild
deleted file mode 100644
index 27993eabc591..000000000000
--- a/app-emulation/e-uae/e-uae-0.8.29_rc4-r3.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic pax-utils
-
-DESCRIPTION="The Ubiquitous Amiga Emulator with an emulation core largely based on WinUAE"
-HOMEPAGE="http://www.rcdrummond.net/uae/"
-# We support _rcX for WIPX versions and _preYYYYMMDD for CVS snapshots.
-if [[ "${PV%%_rc*}" = "${PV}" ]] ; then
- # _pre is used, cvs version
- my_ver=${PV%%_pre*}
- snap_ver=${PV##*_pre}
- S="${WORKDIR}"/${PN}-${my_ver}-${snap_ver}
- SRC_URI="http://www.rcdrummond.net/uae/test/${snap_ver}/${PN}-${my_ver}-${snap_ver}.tar.bz2"
-else
- my_ver=${PV%%_rc*}
- WIP_ver=${PV##*_rc}
- S="${WORKDIR}"/${PN}-${my_ver}-WIP${WIP_ver}
- SRC_URI="http://www.rcdrummond.net/uae/${PN}-${my_ver}-WIP${WIP_ver}/${PN}-${my_ver}-WIP${WIP_ver}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="X dga ncurses sdl alsa oss sdl-sound capslib"
-
-# Note: opposed to ./configure --help zlib support required! Check
-# src/Makefile.am that includes zfile.c unconditionaly.
-RDEPEND="
- sys-libs/zlib
- virtual/cdrtools
- X? (
- x11-libs/libXt
- x11-libs/libxkbfile
- x11-libs/libXext
- x11-misc/xkeyboard-config
- dga? (
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- )
- )
- !X? (
- sdl? ( media-libs/libsdl )
- !sdl? ( sys-libs/ncurses:0= )
- )
- alsa? ( media-libs/alsa-lib )
- !alsa? ( sdl-sound? ( media-libs/sdl-sound ) )
- capslib? ( >=games-emulation/caps-20060612 )
-"
-
-DEPEND="${RDEPEND}
- X? ( dga? ( x11-base/xorg-proto ) )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-tinfo.patch #527628
- "${FILESDIR}"/${P}-no_schily.patch
-)
-
-src_prepare() {
- default
- # Fix for high cpu use when compiled with --disable-audio
- if ! use alsa && ! use sdl-sound && ! use oss ; then
- eapply "${FILESDIR}"/${P}-high-cpu-usage.patch
- fi
- eautoreconf #527628
-}
-
-src_configure() {
- strip-flags
-
- local myconf=()
-
- # Sound setup.
- if use alsa; then
- elog "Choosing alsa as sound target to use."
- myconf=( --with-alsa --without-sdl-sound )
- elif use sdl-sound ; then
- if ! use sdl ; then
- ewarn "sdl-sound is not enabled because sdl USE flag is disabled. Leaving"
- ewarn "sound on oss autodetection."
- myconf=( --without-alsa --without-sdl-sound )
- else
- elog "Choosing sdl-sound as sound target to use."
- ewarn "E-UAE with the SDL audio back-end doesn't work correctly in Linux."
- ewarn "Better use alsa... You've been warned ;)"
- myconf=( --without-alsa --with-sdl-sound )
- fi
- elif use oss ; then
- elog "Choosing oss as sound target to use."
- ewarn "oss will be autodetected. See output of configure."
- myconf=( --without-alsa --without-sdl-sound )
- else
- ewarn "There is no alsa, sdl-sound or oss in USE. Sound target disabled!"
- myconf=( --disable-audio )
- fi
-
- # VIDEO setup. X is autodetected (there is no --with-X option).
- if use X ; then
- elog "Using X11 for video output."
- ewarn "Fullscreen mode is not working in X11 currently. Use sdl."
- myconf+=( --without-curses --without-sdl-gfx )
- use dga && ewarn "To use dga you have to run e-uae as root."
- use dga && myconf+=( --enable-dga --enable-vidmode )
- elif use sdl ; then
- elog "Using sdl for video output."
- myconf+=( --with-sdl --with-sdl-gfx --without-curses )
- elif use ncurses; then
- elog "Using ncurses for video output."
- myconf+=( --with-curses --without-sdl-gfx )
- else
- ewarn "There is no X or sdl or ncurses in USE!"
- ewarn "Following upstream falling back on ncurses."
- myconf+=( --with-curses --without-sdl-gfx )
- fi
-
- # bug #415787
- myconf+=(
- --disable-ui
- $(use_with capslib caps)
- --with-zlib
-
- # And explicitly state defaults:
- --enable-aga
-
- --enable-autoconfig
- --enable-scsi-device
- --enable-cdtv
- --enable-cd32
-
- --enable-bsdsock
-
- --with-libscg-includedir="${EPREFIX}"/usr/include/scsilib
- )
-
- econf ${myconf[@]}
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # The emulator needs to be able to create executable heap
- # - doesn't need trampoline emulation though.
- pax-mark me "${ED%/}/usr/bin/uae"
-
- # Rename it to e-uae
- mv "${ED%/}"/usr/bin/{,e-}uae || die
- mv "${ED%/}"/usr/bin/{,e-}readdisk || die
-
- dodoc docs/* README ChangeLog
-}
diff --git a/app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch b/app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch
deleted file mode 100644
index ad73b34c062c..000000000000
--- a/app-emulation/e-uae/files/e-uae-0.8.29_rc4-high-cpu-usage.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: src/sd-none/sound.c
-===================================================================
-RCS file: /cvsroot/uaedev/uae/src/sd-none/sound.c,v
-retrieving revision 1.4
-diff -u -r1.4 sound.c
---- a/src/sd-none/sound.c 15 Feb 2007 04:47:38 -0000 1.4
-+++ b/src/sd-none/sound.c 25 May 2007 14:47:35 -0000
-@@ -30,10 +30,6 @@
- {
- }
-
--void update_sound (int freq)
--{
--}
--
- void reset_sound (void)
- {
- }
diff --git a/app-emulation/e-uae/files/e-uae-0.8.29_rc4-no_schily.patch b/app-emulation/e-uae/files/e-uae-0.8.29_rc4-no_schily.patch
deleted file mode 100644
index 1a9ebcb408b4..000000000000
--- a/app-emulation/e-uae/files/e-uae-0.8.29_rc4-no_schily.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-configure.in:1134: error: required file 'src/libscg.a' not found
-configure.in:1134: error: required file 'src/libschily.a' not found
-
---- e-uae-0.8.29-WIP4/configure.in
-+++ e-uae-0.8.29-WIP4/configure.in
-@@ -1162,13 +1162,7 @@
- SCSIOBJS="scsiemul.o blkdev.o blkdev-libscg.o"
- UAE_DEFINES="$UAE_DEFINES -DSCSIEMU"
- NEED_THREAD_SUPPORT=yes
-- if [[ "$srcdir" != "." ]]; then
-- AC_CONFIG_LINKS(src/libscg.a:src/libscg.a)
-- AC_CONFIG_LINKS(src/libschily.a:src/libschily.a)
-- UAE_LIBS="$UAE_LIBS $LIBSCG_LIBS"
-- else
-- UAE_LIBS="$UAE_LIBS -L. $SCGLIBS"
-- fi
-+ UAE_LIBS="$UAE_LIBS $LIBSCG_LIBS"
- ],
- [
- AC_MSG_RESULT(no)
diff --git a/app-emulation/e-uae/files/e-uae-0.8.29_rc4-tinfo.patch b/app-emulation/e-uae/files/e-uae-0.8.29_rc4-tinfo.patch
deleted file mode 100644
index 7f94dd20d8db..000000000000
--- a/app-emulation/e-uae/files/e-uae-0.8.29_rc4-tinfo.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- e-uae-0.8.29-WIP4/configure.in
-+++ e-uae-0.8.29-WIP4/configure.in
-@@ -624,6 +624,7 @@
- AC_PATH_XTRA
-
- dnl Check for ncurses
-+AC_CHECK_LIB(tinfo, main, HAVE_TINFO_LIB=yes, HAVE_TINFO_LIB=no)
- AC_CHECK_LIB(ncurses, waddch, HAVE_NCURSES_LIB=yes, HAVE_NCURSES_LIB=no)
-
- dnl Check for SDL
-@@ -793,7 +794,10 @@
-
- if [[ "x$WANT_NCURSES" = "xyes" ]]; then
- if [[ "x$HAVE_NCURSES_LIB" = "xyes" ]]; then
-- GFX_LIBS="-lncurses"
-+ if [[ "x$HAVE_TINFO_LIB" = "xyes" ]]; then
-+ GFX_LIBS="-ltinfo"
-+ fi
-+ GFX_LIBS="$GFX_LIBS -lncurses"
- GFX_CFLAGS=
- GFX_CPPFLAGS=
- GFX_DEP=gfx-curses
diff --git a/app-emulation/e-uae/metadata.xml b/app-emulation/e-uae/metadata.xml
deleted file mode 100644
index 35a11c55489a..000000000000
--- a/app-emulation/e-uae/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- E-UAE is a fork of UAE which intends to merge all the new features of
- WinUAE with UAE.
- </longdescription>
- <use>
- <flag name="capslib">Add CAPS library support</flag>
- <flag name="sdl-sound">Use <pkg>media-libs/sdl-sound</pkg> for audio
- output</flag>
- </use>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 30d5648a56c9..2f8a3f11082d 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -412,9 +412,8 @@ sys-cluster/moosefs
# James Le Cuirot <chewi@gentoo.org> (20 Apr 2019)
# Ancient and long dead upstream. Use app-emulation/fs-uae
-# instead. Removal in 30 days. Bugs #432092, #602966.
+# instead. Removal in 30 days. Bug #432092.
app-emulation/uae
-app-emulation/e-uae
# Miroslav Šulc <fordfrog@gentoo.org> (19 Apr 2019)
# Depends on >=virtual/{jdk,jre}-11 which is masked