summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-02 07:39:00 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-02 07:41:43 +0200
commit0459c14bf1d1d9e32503e6d18df7bb13584e8d9e (patch)
tree1c58052618fe482145036f5d75b2a88e5f93f8ac
parentdev-ruby/sprockets-rails: ruby24 (diff)
downloadgentoo-0459c14b.tar.gz
gentoo-0459c14b.tar.bz2
gentoo-0459c14b.zip
dev-ruby/coffee-rails: add ruby24
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-ruby/coffee-rails/coffee-rails-4.2.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/coffee-rails/coffee-rails-4.2.2-r1.ebuild b/dev-ruby/coffee-rails/coffee-rails-4.2.2-r1.ebuild
new file mode 100644
index 000000000000..25f38aca2f7f
--- /dev/null
+++ b/dev-ruby/coffee-rails/coffee-rails-4.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Coffee Script adapter for the Rails asset pipeline"
+HOMEPAGE="https://github.com/rails/coffee-rails"
+SRC_URI="https://github.com/rails/coffee-rails/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~amd64-linux"
+
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/coffee-script-2.2.0
+ >dev-ruby/railties-4:*"
+
+all_ruby_prepare() {
+ # Avoid dependency on git and bundler.
+ sed -i -e 's/git ls-files/echo/' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Make sure a consistent rails version is loaded.
+ sed -i -e '4igem "rails"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
+}