summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-06-24 21:16:50 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-07-08 15:05:16 +0300
commit045de27d97e469275e204b76c504464056045aa5 (patch)
tree66877761fc2853afd1a9eb279582628df19bfb90
parentsys-libs/kpmcore: 21.04.3 version bump (diff)
downloadgentoo-045de27d97e469275e204b76c504464056045aa5.tar.gz
gentoo-045de27d97e469275e204b76c504464056045aa5.tar.bz2
gentoo-045de27d97e469275e204b76c504464056045aa5.zip
app-text/cmark: update to 0.30.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21412 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.30.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index e7779b22878f..1b6ebbb7e334 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1 +1,2 @@
DIST cmark-0.29.0.tar.gz 234545 BLAKE2B 1571cdf08f85142ff790db811b7973f2d95a7b1c8669af467cbeac1ad0907826a46f7e0e3ba717ba677746406f8372e40b9878f7810d317fa3c0e14db06dc8fb SHA512 06eb110cfd90c9e980c022b7588e28864d15a4da5d07d61ad4b27c6de47367492b9e58e9434e62b07517aa6dc484f17af13916808be3188f38c37d20cbf33112
+DIST cmark-0.30.0.tar.gz 244190 BLAKE2B 71061a472aed262928e1dc9103241d5e73465781238af4c366e79d818c82041932b534015758426c2b2dd6313acadfb6d9be0b931701c67577e8b4421a781ec4 SHA512 53bbb8cdcac5431b88000f69df0aecfc7bd0d9ec0f7bc5a343281ca75e98304ef2674f55f76733acd81f8e8b9079eefabc9b3f3ef7dcd64087497282f17034a9
diff --git a/app-text/cmark/cmark-0.30.0.ebuild b/app-text/cmark/cmark-0.30.0.ebuild
new file mode 100644
index 000000000000..04072de38d26
--- /dev/null
+++ b/app-text/cmark/cmark-0.30.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0.30.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}