summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-10-29 15:00:13 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-10-29 15:00:40 -0400
commit045e9fcbb0f3cbc277ecfb1ebe59d8ad1332bc62 (patch)
tree54b8814485533197ea53c1f11440e4fa8f48ae47
parentdev-libs/libxslt: Stabilize 1.1.34-r2 amd64, #820725 (diff)
downloadgentoo-045e9fcb.tar.gz
gentoo-045e9fcb.tar.bz2
gentoo-045e9fcb.zip
net-misc/ipv6calc: convert econf args to a bash array
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild39
1 files changed, 21 insertions, 18 deletions
diff --git a/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild b/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild
index 9b30664564c8..a5d7e8e70ae5 100644
--- a/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild
+++ b/net-misc/ipv6calc/ipv6calc-4.0.0-r1.ebuild
@@ -30,26 +30,29 @@ src_configure() {
# okay because we want then force enabled.
# --disable-db-as-registry
# --disable-db-cc-registry
+ local myeconfargs=(
+ --disable-bundled-getopt
+ --disable-bundled-md5
+ --enable-shared
+ --enable-dynamic-load
+ --enable-db-ieee
+ --enable-db-ipv4
+ --enable-db-ipv6
+ --disable-dbip
+ --disable-dbip2
+ --disable-external
+ --disable-ip2location
+ --enable-openssl-evp-md5
+ --enable-openssl-md5
+ $(use_enable geoip)
+ $(use_enable cgi mod_ipv6calc )
+ )
+
if use geoip; then
- myconf=$(use_enable geoip)
- myconf+=" --with-geoip-db=${EPREFIX}/usr/share/GeoIP"
+ myeconfargs+=( "--with-geoip-db=${EPREFIX}/usr/share/GeoIP" )
fi
- econf \
- --disable-bundled-getopt \
- --disable-bundled-md5 \
- --enable-shared \
- --enable-dynamic-load \
- --enable-db-ieee \
- --enable-db-ipv4 \
- --enable-db-ipv6 \
- --disable-dbip \
- --disable-dbip2 \
- --disable-external \
- --disable-ip2location \
- --enable-openssl-evp-md5 \
- --enable-openssl-md5 \
- $(use_enable cgi mod_ipv6calc ) \
- ${myconf}
+
+ econf "${myeconfargs[@]}"
}
src_compile() {