summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-06 23:50:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:57 +0100
commit047f89f64f35c06f5b028a333a8025064395cea2 (patch)
treee6f166f436a614bc629e5d1606fcfdd02b2f84c1
parentkde5.eclass: Fork needed xdg.eclass functions pending EAPI-7 porting (diff)
downloadgentoo-047f89f6.tar.gz
gentoo-047f89f6.tar.bz2
gentoo-047f89f6.zip
kde-apps/libkexiv2: Backport exiv2-0.27 support to 18.08.3
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/libkexiv2/files/libkexiv2-18.08.3-cmake.patch67
-rw-r--r--kde-apps/libkexiv2/libkexiv2-18.08.3-r1.ebuild24
2 files changed, 91 insertions, 0 deletions
diff --git a/kde-apps/libkexiv2/files/libkexiv2-18.08.3-cmake.patch b/kde-apps/libkexiv2/files/libkexiv2-18.08.3-cmake.patch
new file mode 100644
index 000000000000..5b8ce9c30c0d
--- /dev/null
+++ b/kde-apps/libkexiv2/files/libkexiv2-18.08.3-cmake.patch
@@ -0,0 +1,67 @@
+From d7e3f14367acaefae38d28ba8d82f2e7aa7a2091 Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Tue, 25 Sep 2018 16:27:02 +0200
+Subject: [PATCH 1/2] Make cmake 3.0 the minimum cmake version
+
+Should fix the build on macOS.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3b1f345..4d3b585 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -9,7 +9,7 @@ project(libkexiv2)
+ message(STATUS "----------------------------------------------------------------------------------")
+ message(STATUS "Starting CMake configuration for: ${PROJECT_NAME}")
+
+-set(CMAKE_MIN_VERSION "2.8.12")
++set(CMAKE_MIN_VERSION "3.0.0")
+ set(ECM_MIN_VERSION "1.1.0")
+ set(REQUIRED_QT_VERSION "5.2.0")
+ set(EXIV2_MIN_VERSION "0.24")
+--
+2.20.1
+
+
+From 2772f91f2a494ed1219f1bb7c6cf3e317892e3c4 Mon Sep 17 00:00:00 2001
+From: Hannah von Reth <vonreth@kde.org>
+Date: Tue, 25 Sep 2018 16:59:20 +0200
+Subject: [PATCH 2/2] Initialize cmake project after cmake_minimum_required was
+ set
+
+---
+ CMakeLists.txt | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4d3b585..d13ef27 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,11 +4,6 @@
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
+-project(libkexiv2)
+-
+-message(STATUS "----------------------------------------------------------------------------------")
+-message(STATUS "Starting CMake configuration for: ${PROJECT_NAME}")
+-
+ set(CMAKE_MIN_VERSION "3.0.0")
+ set(ECM_MIN_VERSION "1.1.0")
+ set(REQUIRED_QT_VERSION "5.2.0")
+@@ -16,6 +11,11 @@ set(EXIV2_MIN_VERSION "0.24")
+
+ cmake_minimum_required(VERSION ${CMAKE_MIN_VERSION})
+
++project(libkexiv2)
++
++message(STATUS "----------------------------------------------------------------------------------")
++message(STATUS "Starting CMake configuration for: ${PROJECT_NAME}")
++
+ # =======================================================
+ # Information to update before to release this library.
+
+--
+2.20.1
diff --git a/kde-apps/libkexiv2/libkexiv2-18.08.3-r1.ebuild b/kde-apps/libkexiv2/libkexiv2-18.08.3-r1.ebuild
new file mode 100644
index 000000000000..abc3e4145964
--- /dev/null
+++ b/kde-apps/libkexiv2/libkexiv2-18.08.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FRAMEWORKS_MINIMAL="5.54.0"
+KDE_BLOCK_SLOT4="false"
+inherit kde5
+
+DESCRIPTION="KDE Image Plugin Interface: an exiv2 library wrapper"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="+xmp"
+
+DEPEND="
+ $(add_qt_dep qtgui)
+ >=media-gfx/exiv2-0.25:=[xmp=]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${PN}-18.12.0-exiv2-0.27.patch"
+)