summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-01 18:20:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-01 18:21:14 +0100
commit048b8a49b5918cb878f67a75ec23aa5c9e9fb54d (patch)
treef6ab7c4353a61a9a1cafd5d0243b8c8591e001b6
parentsys-fs/btrfs-progs: allow asciidoc as an alternative to asciidoctor (diff)
downloadgentoo-048b8a49.tar.gz
gentoo-048b8a49.tar.bz2
gentoo-048b8a49.zip
sys-fs/btrfs-progs: add USE=doc, bug #627418
USE=-doc will install manpages shipped in tarball, USE=doc will regenerate manpages locally. Reported-by: Holger Hoffstätte Closes: https://bugs.gentoo.org/627418 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-5.1-r1.ebuild14
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-9999.ebuild14
2 files changed, 20 insertions, 8 deletions
diff --git a/sys-fs/btrfs-progs/btrfs-progs-5.1-r1.ebuild b/sys-fs/btrfs-progs/btrfs-progs-5.1-r1.ebuild
index 572fe0d9feca..033e0ad66d1c 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-5.1-r1.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-5.1-r1.ebuild
@@ -27,7 +27,7 @@ HOMEPAGE="https://btrfs.wiki.kernel.org"
LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
-IUSE="+convert python reiserfs static static-libs +zstd"
+IUSE="+convert doc python reiserfs static static-libs +zstd"
RESTRICT=test # tries to mount repared filesystems
@@ -63,9 +63,11 @@ DEPEND="${RDEPEND}
)
"
BDEPEND="
- || ( >=app-text/asciidoc-8.6.0 dev-ruby/asciidoctor )
- app-text/docbook-xml-dtd:4.5
- app-text/xmlto
+ doc? (
+ || ( >=app-text/asciidoc-8.6.0 dev-ruby/asciidoctor )
+ app-text/docbook-xml-dtd:4.5
+ app-text/xmlto
+ )
"
if [[ ${PV} == 9999 ]]; then
@@ -99,6 +101,7 @@ src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
+ $(use_enable doc documentation)
$(use_enable elibc_glibc backtrace)
$(use_enable python)
$(use_enable static-libs static)
@@ -120,4 +123,7 @@ src_install() {
emake V=1 DESTDIR="${D}" install "${makeargs[@]}"
newbashcomp btrfs-completion btrfs
use python && python_optimize
+
+ # install prebuilt subset of manuals
+ use doc || doman Documentation/*.[58]
}
diff --git a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
index 35aaf524c916..4680b387969c 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
@@ -27,7 +27,7 @@ HOMEPAGE="https://btrfs.wiki.kernel.org"
LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
-IUSE="+convert python reiserfs static static-libs +zstd"
+IUSE="+convert doc python reiserfs static static-libs +zstd"
RESTRICT=test # tries to mount repared filesystems
@@ -63,9 +63,11 @@ DEPEND="${RDEPEND}
)
"
BDEPEND="
- || ( >=app-text/asciidoc-8.6.0 dev-ruby/asciidoctor )
- app-text/docbook-xml-dtd:4.5
- app-text/xmlto
+ doc? (
+ || ( >=app-text/asciidoc-8.6.0 dev-ruby/asciidoctor )
+ app-text/docbook-xml-dtd:4.5
+ app-text/xmlto
+ )
"
if [[ ${PV} == 9999 ]]; then
@@ -95,6 +97,7 @@ src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
+ $(use_enable doc documentation)
$(use_enable elibc_glibc backtrace)
$(use_enable python)
$(use_enable static-libs static)
@@ -116,4 +119,7 @@ src_install() {
emake V=1 DESTDIR="${D}" install "${makeargs[@]}"
newbashcomp btrfs-completion btrfs
use python && python_optimize
+
+ # install prebuilt subset of manuals
+ use doc || doman Documentation/*.[58]
}