summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-06-05 12:56:24 +0200
committerPacho Ramos <pacho@gentoo.org>2017-06-05 12:57:07 +0200
commit0491253b5aa2fff753e369dd92a2658824e7f5ce (patch)
treec853a4f22ed5f19e59fa3521031c1e77e0f72115
parentMerge branch 'cleanup' (diff)
downloadgentoo-0491253b.tar.gz
gentoo-0491253b.tar.bz2
gentoo-0491253b.zip
sys-kernel/git-sources: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.12_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index c8e627604d9d..4f8f5573b6aa 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-4.11.tar.xz 95447768 SHA256 b67ecafd0a42b3383bf4d82f0850cbff92a7e72a2
DIST patch-4.12-rc1.patch 89253799 SHA256 516dc994c0d1872f27bb83e07f6d2dd506594ae0bc88e5a11e5637dc2b446f2f SHA512 d58b40b44923ffd8d51c58c4ea2c5de75b766888bd65147c308441e77b56deda8476f211edcadc2eb2e4959b35d2a27b4edcb3bd3261787a9f1d0ae491e92200 WHIRLPOOL 0e388627277a97af05bf3f3fff09c03bac2ec60bdc56feb0cd2664aa73c6ef150be50cbaba6fa866911ea3e1074b7c55b6dfb906684b6bb4b1dcd8028887cb1e
DIST patch-4.12-rc2.patch 89563541 SHA256 76e32580cc6fa58e016453856267d61e2b2c464d3bf6808f26c32de9729023fa SHA512 f3ada61c34ff3c39e4bc76fb62a0bfa23e21f4a6f40caa8b51085da57c1938878a070856a7bd2f0abaeb353fbc86eb5e07da466edcabfb5d34d7edf5f4b00655 WHIRLPOOL b356e682df8ec325137b09b9f935a715e0a0d5eb3a6b0e42e3ab51d1702044c4741309cc861767a53a9b0eb79663146b58b2414e910a103d595b6232ff8c4cac
DIST patch-4.12-rc3.patch 89897831 SHA256 d7cd828bdeb0d8b2a584ae87449ab88df8f4344d04add02a4e1ada8067ddbd34 SHA512 82ada025b3b28ecd9effccc4c414c4e6f1dd24c06f4f62eced557e30ccc41c1575927129b6c7dd956ad99d8561522ed5dc3255037b6c3fcedef88b9aa11ebaa4 WHIRLPOOL a6af83a4918a60c2b0fc77617c374751a1fc5bf37d5a10abcffc07bf9686a3904d49546b28a33481c8f8aa8ab0cd9fb410f8ce709049223b39f3569f9ddec6fb
+DIST patch-4.12-rc4.patch 90081481 SHA256 39240c2f354b303894c77ff14a371d4d05cf4425b7e90135fb72d4cf66df0039 SHA512 0672cf1768f46d9eaed2d47ddffbcaee7b8be9172b479aa037747794225286eb19fffa72bf9f4b401fb4e83de4328bab97405d812e9aeea43ea68cc418bb23a0 WHIRLPOOL 3cead50e6cb5cd794652333772249fcfeebb2ff445922268653cf852c4bbc0ad3bd4d629bab3f6e8fb484c574431a277c01543fada73229d9ebbcefd2ca49870
diff --git a/sys-kernel/git-sources/git-sources-4.12_rc4.ebuild b/sys-kernel/git-sources/git-sources-4.12_rc4.ebuild
new file mode 100644
index 000000000000..77ebfa1611cb
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.12_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.11"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}