summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-01-28 12:47:07 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-01-28 12:47:19 +0100
commit0495e9a64d8a396961eb7768551a54c5fc1408e9 (patch)
treef45c20810db766ba56799b247a3c7252ac3f5c47
parentdev-lisp/sbcl: don't call etags (diff)
downloadgentoo-0495e9a64d8a396961eb7768551a54c5fc1408e9.tar.gz
gentoo-0495e9a64d8a396961eb7768551a54c5fc1408e9.tar.bz2
gentoo-0495e9a64d8a396961eb7768551a54c5fc1408e9.zip
net-analyzer/zabbix: fixed wabapp-config error on pkg_prerm()
Closes: https://bugs.gentoo.org/767688 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--net-analyzer/zabbix/zabbix-3.0.31-r2.ebuild6
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.27-r1.ebuild4
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.28.ebuild4
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.6-r1.ebuild4
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.7.ebuild6
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.8.ebuild4
-rw-r--r--net-analyzer/zabbix/zabbix-5.2.2-r1.ebuild4
-rw-r--r--net-analyzer/zabbix/zabbix-5.2.3.ebuild6
-rw-r--r--net-analyzer/zabbix/zabbix-5.2.4.ebuild4
9 files changed, 39 insertions, 3 deletions
diff --git a/net-analyzer/zabbix/zabbix-3.0.31-r2.ebuild b/net-analyzer/zabbix/zabbix-3.0.31-r2.ebuild
index a0c92d82004e..aa1e12740317 100644
--- a/net-analyzer/zabbix/zabbix-3.0.31-r2.ebuild
+++ b/net-analyzer/zabbix/zabbix-3.0.31-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -348,3 +348,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-4.0.27-r1.ebuild b/net-analyzer/zabbix/zabbix-4.0.27-r1.ebuild
index b13d6cef7467..b20bafc87ab0 100644
--- a/net-analyzer/zabbix/zabbix-4.0.27-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.27-r1.ebuild
@@ -347,3 +347,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-4.0.28.ebuild b/net-analyzer/zabbix/zabbix-4.0.28.ebuild
index 0b9b0cc693fc..6eb470b33c50 100644
--- a/net-analyzer/zabbix/zabbix-4.0.28.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.28.ebuild
@@ -347,3 +347,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-5.0.6-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.6-r1.ebuild
index 688147d3fb15..90a6d16b59ee 100644
--- a/net-analyzer/zabbix/zabbix-5.0.6-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.6-r1.ebuild
@@ -344,3 +344,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-5.0.7.ebuild b/net-analyzer/zabbix/zabbix-5.0.7.ebuild
index 8f6e95562365..37470326b6db 100644
--- a/net-analyzer/zabbix/zabbix-5.0.7.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -344,3 +344,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-5.0.8.ebuild b/net-analyzer/zabbix/zabbix-5.0.8.ebuild
index 39cc07a3b42e..37470326b6db 100644
--- a/net-analyzer/zabbix/zabbix-5.0.8.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.8.ebuild
@@ -344,3 +344,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-5.2.2-r1.ebuild b/net-analyzer/zabbix/zabbix-5.2.2-r1.ebuild
index 688147d3fb15..90a6d16b59ee 100644
--- a/net-analyzer/zabbix/zabbix-5.2.2-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.2.2-r1.ebuild
@@ -344,3 +344,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-5.2.3.ebuild b/net-analyzer/zabbix/zabbix-5.2.3.ebuild
index 8f6e95562365..37470326b6db 100644
--- a/net-analyzer/zabbix/zabbix-5.2.3.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -344,3 +344,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}
diff --git a/net-analyzer/zabbix/zabbix-5.2.4.ebuild b/net-analyzer/zabbix/zabbix-5.2.4.ebuild
index 39cc07a3b42e..37470326b6db 100644
--- a/net-analyzer/zabbix/zabbix-5.2.4.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.2.4.ebuild
@@ -344,3 +344,7 @@ pkg_postinst() {
esac
fi
}
+
+pkg_prerm() {
+ (use frontend || use server) && webapp_pkg_prerm
+}