summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2019-06-18 14:11:23 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2019-06-19 09:32:15 +0200
commit04985d5d9f35c0810aa070db1c0244bd027c6f28 (patch)
tree65238a382714bcf41ac7a086987130776ed0a841
parentdev-util/redo: Fix test env (diff)
downloadgentoo-04985d5d9f35c0810aa070db1c0244bd027c6f28.tar.gz
gentoo-04985d5d9f35c0810aa070db1c0244bd027c6f28.tar.bz2
gentoo-04985d5d9f35c0810aa070db1c0244bd027c6f28.zip
dev-util/boost-build: run hprefixify on engine/Jambase
engine/Jambase defines default locations for boost-build, which should stick to the EPREFIX where installed to, not the host system. The breakage is in prefix-stack, where the boost ebuild does add the stacked EPREFIX only as --boost-build flag, but not BROOT. Although this is questionable, we really should use our own prefix as fallback. Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
-rw-r--r--dev-util/boost-build/boost-build-1.65.0.ebuild5
-rw-r--r--dev-util/boost-build/boost-build-1.70.0.ebuild3
2 files changed, 5 insertions, 3 deletions
diff --git a/dev-util/boost-build/boost-build-1.65.0.ebuild b/dev-util/boost-build/boost-build-1.65.0.ebuild
index e7011fc99ca3..4b42b41f17ce 100644
--- a/dev-util/boost-build/boost-build-1.65.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.65.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
RESTRICT="test"
PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic python-single-r1 toolchain-funcs versionator
+inherit eutils flag-o-matic prefix python-single-r1 toolchain-funcs versionator
MY_PV="$(replace_all_version_separators _)"
@@ -81,6 +81,7 @@ src_prepare() {
}
src_configure() {
+ hprefixify engine/Jambase
if use python; then
# replace versions by user-selected one (TODO: fix this when slot-op
# deps are available to always match the best version available)
diff --git a/dev-util/boost-build/boost-build-1.70.0.ebuild b/dev-util/boost-build/boost-build-1.70.0.ebuild
index 98eb1a3631a7..954e06df9453 100644
--- a/dev-util/boost-build/boost-build-1.70.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.70.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit flag-o-matic python-single-r1 toolchain-funcs
+inherit flag-o-matic prefix python-single-r1 toolchain-funcs
MY_PV="$(ver_rs 1- _)"
@@ -83,6 +83,7 @@ src_prepare() {
}
src_configure() {
+ hprefixify engine/Jambase
if use python; then
# replace versions by user-selected one (TODO: fix this when slot-op
# deps are available to always match the best version available)