summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-07-07 05:34:11 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-07-07 05:35:52 -0400
commit049fe45baceb3654fc454f21e3d0a1ea4578206e (patch)
tree473c6d821c411ee11af30a613dc9490cc4e517cd
parentmedia-gfx/cairosvg: Version Bump (diff)
downloadgentoo-049fe45b.tar.gz
gentoo-049fe45b.tar.bz2
gentoo-049fe45b.zip
dev-python/weasyprint: Version Bump
Now depends on packages to pass tests fixing bug 580536. Now depends on x11-libs/gdk-pixbuf to enable support for additional image formats. Correctly depend on >=media-gfx/cairosvg-1.0.20 fixing bug 620286. Bug: 580536, 620286 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-0.39.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 8ee4a269961b..8ad2e6805a85 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST WeasyPrint-0.29.tar.gz 1418105 SHA256 4edf5538b330be3e559f006db76a5a948c25f3792746aafb20f2a9d6185f0e71 SHA512 3875240b7bed6991372f6a45f82d32f0d2f3add29ab1937001c5559368405737d185aa85871358730989a91ee6b17e62cc21535735c884c47705d0d2d38bb167 WHIRLPOOL cbefe32d42e5bbc26993b58f88b2ebc26291579dd717805c8fc9c54d41fe69b3a05eb8f301e9c21b426766404c9a683cce6c115ed8193456d17c83b44c8513a9
+DIST WeasyPrint-0.39.tar.gz 386613 SHA256 ed0be652bd396a9b818f015c8bc5fb32040864ee86cda6f0160cdef1dd4f42d0 SHA512 668eed8c4f2502b3412166ea8e7b15b838b971b175ac3ec2370097b83557070684fa7bc9c62c3222056294093781649f263aba756091fb87d50ceea339e32e43 WHIRLPOOL d7b987dbef301346a83418f7a8796f0d7c3076c5b8aadc66da1779e86198864e8c6c91ea3edc7d3ebbe8820a0e5a73b11c07a7cf1b7b7a9a9c3aeebb900d7490
diff --git a/dev-python/weasyprint/weasyprint-0.39.ebuild b/dev-python/weasyprint/weasyprint-0.39.ebuild
new file mode 100644
index 000000000000..0c87b9ee57e0
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.39.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org https://github.com/Kozea/WeasyPrint"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="jpeg jpeg2k test tiff"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+RDEPEND="
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf[jpeg?,jpeg2k?,tiff?]
+ x11-libs/pango:0/0
+ >=dev-python/cairocffi-0.5[${PYTHON_USEDEP}]
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect-0.6[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-1.0.20[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-flake8[${PYTHON_USEDEP}]
+ dev-python/pytest-isort[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}