summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-21 13:39:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-21 16:37:42 +0100
commit04ad37cac6604e4b3503541f5f4537598ffc2afd (patch)
tree22db4df00be109069b942fb2c4021d643c3ccd53
parentsys-devel/llvm-common: Remove 13.0.1-rc{1,2} (diff)
downloadgentoo-04ad37cac6604e4b3503541f5f4537598ffc2afd.tar.gz
gentoo-04ad37cac6604e4b3503541f5f4537598ffc2afd.tar.bz2
gentoo-04ad37cac6604e4b3503541f5f4537598ffc2afd.zip
dev-python/lit: Switch to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lit/lit-13.0.1.9999.ebuild8
-rw-r--r--dev-python/lit/lit-13.0.1_rc3.ebuild6
-rw-r--r--dev-python/lit/lit-14.0.0.9999.ebuild8
3 files changed, 14 insertions, 8 deletions
diff --git a/dev-python/lit/lit-13.0.1.9999.ebuild b/dev-python/lit/lit-13.0.1.9999.ebuild
index 37168fbde9bd..89c5315a5acb 100644
--- a/dev-python/lit/lit-13.0.1.9999.ebuild
+++ b/dev-python/lit/lit-13.0.1.9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 llvm.org
@@ -20,7 +21,8 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
+ sys-devel/llvm
+ )"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
diff --git a/dev-python/lit/lit-13.0.1_rc3.ebuild b/dev-python/lit/lit-13.0.1_rc3.ebuild
index 49771827209c..89c5315a5acb 100644
--- a/dev-python/lit/lit-13.0.1_rc3.ebuild
+++ b/dev-python/lit/lit-13.0.1_rc3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 llvm.org
@@ -20,7 +21,8 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
+ sys-devel/llvm
+ )"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals
diff --git a/dev-python/lit/lit-14.0.0.9999.ebuild b/dev-python/lit/lit-14.0.0.9999.ebuild
index 37168fbde9bd..89c5315a5acb 100644
--- a/dev-python/lit/lit-14.0.0.9999.ebuild
+++ b/dev-python/lit/lit-14.0.0.9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 llvm.org
@@ -20,7 +21,8 @@ RESTRICT="!test? ( test )"
BDEPEND="
test? (
dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
+ sys-devel/llvm
+ )"
LLVM_COMPONENTS=( llvm/utils/lit )
llvm.org_set_globals