summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-26 01:37:46 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-26 01:54:08 +0100
commit04b05854ce34e131c408759072dc46f5c204f04b (patch)
tree4f5fd843eefb480e36bdfb5d5cf3e2ed6226258e
parentdev-ml/reason: drop old 3.9.0-r1 (diff)
downloadgentoo-04b05854.tar.gz
gentoo-04b05854.tar.bz2
gentoo-04b05854.zip
dev-ml/reason: bump to 3.11.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-ml/reason/Manifest1
-rw-r--r--dev-ml/reason/reason-3.11.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/reason/Manifest b/dev-ml/reason/Manifest
index 86e36fac92ad..93920496d1ab 100644
--- a/dev-ml/reason/Manifest
+++ b/dev-ml/reason/Manifest
@@ -1 +1,2 @@
DIST reason-3.10.0.tar.gz 668962 BLAKE2B 11ab06cf12d2bd2381a6e12bd0dd7627ce454356db21ad189acaea7d24dac7e3647c10bb4478ded41f946d2d982b20988e448eb63ba4b68574bdbafa2984d0b7 SHA512 9be379b3953f57096139d766ef7c55d89bf70be4a8153177b9812bfa69c4260ee91dfeb87df2b71d63840f612e53e46cd2867085bdcfc7040e53817a8ff92225
+DIST reason-3.11.0.tar.gz 699692 BLAKE2B c377e7ccb222ade2f0a5a9b50147a045fb10a95d7e3a8a9ce91674f76a3174ef169f5575ecde7004db2a43350ac8e7cc73315eefcda57b98c9b3d6cc83ed13bd SHA512 71b70e06afbc193c1c4b379c570347e4f971ed001d60e73cf4a745a9bc110e78d329d5ce5334b59aacb7dbe8d2f12f50b7c6786c9a35fff445da0d26f6a87f7d
diff --git a/dev-ml/reason/reason-3.11.0.ebuild b/dev-ml/reason/reason-3.11.0.ebuild
new file mode 100644
index 000000000000..d9655ff84950
--- /dev/null
+++ b/dev-ml/reason/reason-3.11.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io/
+ https://github.com/reasonml/reason/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/reasonml/${PN}.git"
+else
+ SRC_URI="https://github.com/reasonml/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/dune-build-info:=
+ dev-ml/fix:=
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_derivers:=
+ dev-ml/ppxlib:=
+ dev-ml/utop:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.10.0-fake-git-version.patch" )
+
+src_install() {
+ dune-install reason rtop
+
+ dodoc *.md docs/*.md
+}